SuSE Linux 9.0 Pro and ANY modem...

I recently loaded SuSE Linux 9.0 Pro on my machine, and the long and short of it is that NO MODEM will work with it.

I've set up the Earthlink account correctly; I setup KPPP correctly (both from my own knowledge and from the KPPP Help File); I utilized the setserial command and created symbolic links from /dev/ttyS0 to /dev/modem; I've done darn near everything that is obvious.  However, no matter what I do, when I go into KPPP and do a 'Modem Query', it will find the modem, and say "Modem Ready" but when it finishes querying the AT's, it brings up a box and displays....nothing.  Nothing on any of the AT lines.  This is the case for ANY modem.  I got this for 3 separate modems.  Once with a Win/Linmodem, once with an external Creative Modem Blaster Flash 56K (parallel connection), and once with a US Robotics 5610B controller based modem.  (This last modem had NO problems being setup under RH9.)

Can anyone help?
johnstaggsAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

shivsaCommented:

u can try to create devices one more time and see if it works.

cd dev; ./MAKEDEV -v ttyS0

MAKEDEV is a script to create devices.  It's located on redhat boxes at /dev/MAKEDEV and you can find more info with:
man 8 MAKEDEV(it should be on suse too.)
jlevieCommented:
The first two modems you've tried seem a bit iffy to me as they are non-standard items. The US Robotics should work if the hardware is correctly detected. The first thing I'd suggest is that you disable the any on-board COM ports and that you see if your BIOS allows disabling on PnP mode. Frequently that's all that's necessary to get a controller based PCI modem to work. Then I'd suggest that you use 'dmesg' to see if the system detected the modem and what tty device has been allocated to it.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Karl Heinz KremerCommented:


No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
Delete/No Refund
Please leave any comments here within the next four days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

khkremer
EE Cleanup Volunteer
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.