Solved

Is this my problem --> 'ip audit name OutAttack attack action drop reset'

Posted on 2003-11-26
9
517 Views
Last Modified: 2010-04-09
Here is the situation:

We have been trying to add a windows 2000 server to our NT4.0 network for about a week. Everytime we bring the server up with the 2k OS, it seems to be flooding the network and brings 'outside access in' and 'inside access out' to a grinding halt. As soon as we unplug the cable from the box, we're all good.

Here's what I have done:
reinstalled 4x.
changed NICs 2x.
change machines 3x.

For some reason I come back to the PIX and the following line: 'ip audit name OutAttack attack action drop reset'. Could this be a possible culprit in that the server is trying to intially look for a AD DC and is flooding the network with requests. Just a thought. I'm really at a loss on this.

One other thing I did see was that the network is using two 3com 24prt hubs as its backbone. Needless to say that this is not helping, though I don't believe this is causing the current issue. I say this because other 2k servers were added to the net with these hubs with no issues. Thought they were installed prior to the PIX 501.

Here is my config:

PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 6ztx/UAvbLi8D0Sn encrypted
passwd 6ztx/UAvbLi8D0Sn encrypted
hostname pixfirewall
domain-name ***.net
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
name 192.168.1.100 Bigdog
name 192.168.1.3 ***pms
name 192.168.1.5 owa***
name 192.168.1.1 APPSERVER
object-group service pcANY tcp
  description pcANYwhere
  port-object range 65301 65301
  port-object eq pcanywhere-data
  port-object range pcanywhere-data 5632
object-group service TermServ tcp
  description RDP
  port-object range 3389 3399
access-list inside_access_in remark outbound
access-list inside_access_in permit tcp any any
access-list letmein remark inbound traffic
access-list letmein permit tcp any host *.*.*.194 eq smtp
access-list letmein permit tcp any host *.*.*.194 eq www
access-list letmein permit tcp any host *.*.*.194 eq https
access-list letmein permit tcp any host *.*.*.194 eq pop3
access-list letmein permit tcp any host *.*.*.194 eq imap4
access-list letmein permit tcp any host *.*.*.194 eq pcanywhere-data
access-list letmein permit tcp any host *.*.*.194 eq 3389
access-list letmein permit udp any host *.*.*.194 eq 3389
access-list letmein permit udp any host *.*.*.194 eq 65301
access-list letmein permit tcp any host *.*.*.194 eq 65301
access-list letmein permit udp any host *.*.*.194 eq 143
access-list letmein permit udp any host *.*.*.194 eq 220
access-list letmein permit tcp any host *.*.*.194 eq 220
access-list letmein permit tcp any host *.*.*.194 eq 585
access-list letmein permit udp any host *.*.*.194 eq 585
access-list letmein permit udp any host *.*.*.194 eq 993
access-list letmein permit tcp any host *.*.*.194 eq 993
access-list nat0 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.1.20 255.255.255.0
ip audit name OutAttack attack action drop reset
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.2.1-192.168.2.254
pdm location Bigdog 255.255.255.255 inside
pdm location ***pms 255.255.255.255 inside
pdm location owa*** 255.255.255.255 inside
pdm location APPSERVER 255.255.255.255 inside
pdm location x.x.x.244 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nat0
nat (inside) 1 192.168.1.0 255.255.255.0 0 0
static (inside,outside) udp interface 143 ***pms 143 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface imap4 ***pms imap4 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pop3 ***pms pop3 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www owa*** www netmask 255.255.255.255 0 0
static (inside,outside) udp interface 3389 owa*** 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 owa*** 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https owa*** https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pcanywhere-data APPSERVER pcanywhere-data netmask 255.255.255.255 0 0
static (inside,outside) udp interface 5631 APPSERVER 5631 netmask 255.255.255.255 0 0
static (inside,outside) udp interface pcanywhere-status APPSERVER pcanywhere-status netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 5632 APPSERVER 5632 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 65301 APPSERVER 65301 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 65301 APPSERVER 65301 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp ***pms smtp netmask 255.255.255.255 0 0
access-group letmein in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http x.x.x.244 255.255.255.255 outside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map outside_map 90 ipsec-isakmp dynamic dynmap
crypto map outside_map interface outside
isakmp enable outside
isakmp identity address
isakmp policy 20 authentication rsa-sig
isakmp policy 20 encryption des
isakmp policy 20 hash sha
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
isakmp policy 30 authentication pre-share
isakmp policy 30 encryption des
isakmp policy 30 hash md5
isakmp policy 30 group 2
isakmp policy 30 lifetime 86400
vpngroup ***-VPN-USERS idle-time 1800
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 dns-server *.*.*.250
vpngroup vpn3000 wins-server APPSERVER
vpngroup vpn3000 split-tunnel 101
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ++++++++
telnet x.x.x.244 255.255.255.255 outside
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh ***pms 255.255.255.255 inside
ssh owa*** 255.255.255.255 inside
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 60
console timeout 0
vpdn group pppoex request dialout pppoe
vpdn group pppoex localname ****tron
vpdn group pppoex ppp authentication pap
vpdn username ****tron password ++++++++*
dhcpd address 192.168.1.22-192.168.1.129 inside
dhcpd dns *.*.*.5 *.*.*.1
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain ****tron.com
dhcpd auto_config outside
terminal width 80
Cryptochecksum:84f285e05ae85fc2e3079b04fc38b2e3
: end

Thanks.
0
Comment
Question by:cepolly
  • 5
  • 4
9 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 9826013
Sounds like this system is infected with Welchia/MSBLAST. Highly suggest that you bring it up stand-alone and check it thoroughly...

Although you defined the audit policy, I don't see where you actually applied it to an interface..
I would expect to see something like:
ip audit interface inside OutAttack

Since you have not actually applied it to the interface, that sort of rules out this as the culprit.
0
 
LVL 1

Author Comment

by:cepolly
ID: 9826058
Hmm.

But this is the 3rd system tried and this doesn't happen to any other boxes.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9826143
I don't quite understand your last comment...
>this doesn't happen to any other boxes
What doesn't happen - upgrading to Win2k brings the network to a halt?

You have no other Win2k machines on the network?

Do you have enough licenses on the 501 to support adding one more system?

Suggest you put a sniffer on the LAN and see what's really going on when you try this.
Ethereal is free:
http://www.ethereal.com
So is Probe
http://www.objectplanet.com/Probe/

You can get a 30day eval of LanHound:
http://www.sunbelt-software.com/print.cfm?id=925
0
 
LVL 1

Author Comment

by:cepolly
ID: 9826220
Sorry about that,

No other servers are having this effect on the network.
We have installed other win2k servers on the network without any incident prior to our PIX installation.
The network outage issue began to occur 3 days ago.
Since that time we have tried installing several machines with win2k on the network, all with the same result; network flooded.
We have more than enough licenses.

i'll put a sniffer on the network.
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 79

Expert Comment

by:lrmoore
ID: 9826269
If the PIX is the most recent addition to the network, try adding this:

sysopt noproxyarp inside

0
 
LVL 1

Author Comment

by:cepolly
ID: 9826354
can you tell me a little more about this command?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9826432
This disables proxy arp on the inside interface.
Is the PIX your default gateway for everyone?
This explains a little bit about proxy arp:
http://www.cisco.com/warp/public/105/5.html
0
 
LVL 1

Author Comment

by:cepolly
ID: 9826437
yes it is
0
 
LVL 1

Author Comment

by:cepolly
ID: 9984943
Lrmoore,

Sorry it took so long to re-post.

It was the Nachi virus. Good call!

We also had another PC with a bad NIC which added to the problem. We replaced the NIC and isolated the PC with the virus causing the problem.

Thanks again,
Cepolly
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now