unable to get servlet working

I am trying to deploy an application in Tomcat 5.0

I have put the JSP pages in
   /webapps/ROOT/test/index.jsp
and the servlets in the package
   /webapps/ROOT/WEB-INF/classes/sample/Logintest.class
and the WEB.XML in
   /webapps/ROOT/WEB-INF/web.xml

but I get .
Am i missing something , i have the same thing running Tomcat 4.0.6 and have nor problem . I am using a linux m/c

The requested resource (/servlet/sample.Logintest) is not available.

Thank q
LVL 3
applekannaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TimYatesCommented:
try it with a servlet mapping in web.xml:

  <servlet>
    <servlet-name>logintest</servlet-name>
    <servlet-class>sample.Logintest</servlet-class>
  </servlet>
  <servlet-mapping>
    <servlet-name>logintest</servlet-name>
    <url-pattern>*.login</url-pattern>
  </servlet-mapping>

restart Tomcat, and go to:

http://localhost:8080/test.login
jimmackCommented:
Have you tried the URL without the /servlet/ ?
applekannaAuthor Commented:
yes we have it running on a tomcat 4.0.6 already , but unable to get it to deploy on a new machine and we installed tomcat 5.

OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

jimmackCommented:
Morning Tim.  You're very active lately ;-)
jimmackCommented:
From the Tomcat 5 Release Notes:

------------------------
Enabling invoker servlet:
------------------------

Starting with Tomcat 4.1.12, the invoker servlet is no longer available by
default in all webapps. Enabling it for all webapps is possible by editing
$CATALINA_HOME/conf/web.xml to uncomment the "/servlet/*" servlet-mapping
definition.

Using the invoker servlet in a production environment is not recommended and
is unsupported.

This might explain it ;-)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TimYatesCommented:
> This might explain it ;-)

And my solution should fix it ;-)

Hee hee!

>  Morning Tim.  You're very active lately ;-)

Messing round with Axis, CSS, SOAP, RPC and stuff...  It's cool, but I come here to think about other things, and try to have a revelation about what I'm doing wrong ;-)

Hee hee

Tim
TimYatesCommented:
PS:  Morning!!!! :-)
CEHJCommented:
>>Messing round with Axis, CSS, SOAP, RPC and stuff.

Well there's a coincidence - so am i - but not with much enthusiasm ;-) Maybe we should offline about it? ;-)
TimYatesCommented:
:-) You can find my contact details with a bit of investigation into my profile ;-)  hee hee
applekannaAuthor Commented:
Thx a lot guys, it worked like a charm.
jimmackCommented:
;-)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Java EE

From novice to tech pro — start learning today.