?
Solved

How do I Block Remote Desktop via the Firewall?

Posted on 2003-11-27
11
Medium Priority
?
3,825 Views
Last Modified: 2013-11-16
I'm using a Pix 515E software 6.2(3).  I have setup an XP Machine in my office and connected through the Firewall to my Home Computer Windows 2003 Server using Remote DeskTop..no logging of this activity is present.  My fear is users will be able to do this and surf the web on their home computer by-passing my web inspector monitor.  I have tried blocking ports GT 1024 with no success.....do I need to block a certain port or protocol comm???   Any Suggestions!
0
Comment
Question by:blc92562
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +3
11 Comments
 
LVL 49

Assisted Solution

by:sunray_2003
sunray_2003 earned 450 total points
ID: 9832284
0
 

Author Comment

by:blc92562
ID: 9832362
Sunray:

THanks for the Link...This is the first thing I tried, I had the Office workstation connected when I applied the ACL to block 3389 and it locked the Office Computer.... I shut down RemoteDesktop and restarted... connected to the Home Computer with no problems.

After aplling the ACl I ran the command clear xlate and clear Local-host.  I will try this again and probably just save to flash and reboot the pix to insure the acl takes effect.

Any ideas why no logging is happening with this remote desktop?  The Pix logs all the internet sites but not the remote desktop connections.
0
 
LVL 13

Expert Comment

by:WillHudson
ID: 9832366
How about just disabling the remote desktop service?
0
Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

 

Author Comment

by:blc92562
ID: 9832405
That’s definitely an option when it’s all said and done I will probably block the ports and create a Group Policy to disable the functionality.
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 9832432
Yup 3389 is the usuall port to block check you pix config for an inbound deny for 3389 from any to any, you can also apply an outbound deny as well if you are really paranoid.

It would seem you have ports open anyway? this is not good! the bottom of your access list should have a "deny any any"
to lock all the non permitted ports down.

Pete
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 9832465
0
 
LVL 7

Accepted Solution

by:
Robing66066 earned 450 total points
ID: 9832898
You probably won't get away with setting up an inbound block because the traffic in question has the ack bit set and will be allowed back in by NAT.

Instead, block the inside connection to 3389 for all internal addresses.

I think you would add something like this:

access-list inside_access_in deny tcp any any eq 3389
access-list inside_access_in permit ip any any
access-group inside_access_in in interface inside

Good luck!
0
 

Author Comment

by:blc92562
ID: 9833181

I have been told by TAC that all outside ports are closed by default and all
Inside ports are open by default.


1. This is what I have applied to inside Interface

access-list acl_inside deny tcp any any eq 3389
access-list acl_inside deny tcp any any eq 135
access-list acl_inside deny udp any any eq 135
access-list acl_inside deny udp any any eq tftp
access-list acl_inside deny tcp any any eq 137
access-list acl_inside deny udp any any eq netbios-ns
access-list acl_inside deny tcp any any eq 138
access-list acl_inside deny udp any any eq netbios-dgm
access-list acl_inside deny tcp any any eq netbios-ssn
access-list acl_inside deny udp any any eq 139
access-list acl_inside deny tcp any any eq 445
access-list acl_inside deny tcp any any eq 593
access-list acl_inside permit ip any any


access-group acl_inside in interface inside


2. Would it be safer to close ports to inside Interface and only open the ones I need?  I believe if I add one permit statement the Pix automatically denies all traffic i.e. automatically adds a access-list acl_inside deny ip any any

access-list acl_inside permit tcp any any eq 80
access-list acl_inside permit tcp any any eq 21
access-list acl_inside permit tcp any any eq 53
access-group acl_inside in interface inside

What ports should automatically be set to open?
0
 
LVL 7

Expert Comment

by:Robing66066
ID: 9833474
It is safer, but can become a bit of a management nightmare, specifically because you have to figure out what ports to keep open.  

If I was tempted to do it, I would include 25, (or 110), 20 (FTP data channel), 443, and any other port that your inside applications require.  Even then, you'll have trouble downloading from some sites.  

I would also include the 'access-list acl_inside deny ip any any' line to the config.  If you do, it will help you out a lot when troubleshooting the ACL.  With it, while you are troubleshooting, you can see how often packets are hitting the deny line and are being blocked, without it, you only see the permit lines and how often they get hit.

But to be honest, I wouldn't do it this way.  I would go with the permit all and block as per the list you provided.  If you are concerned about people doing remote control of their machines at home, you aren't going to be able to stop them this way.  At best, you will stop the less determined.  Most of the remote takeover packages can be configured as to what port to use.  In this case, a home user could just change the port from default to port 80, and off they go.  

Good luck!
0
 

Author Comment

by:blc92562
ID: 9833537
Thanks for the assistance!!!
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 9833563
as long as you allow Remote DeskTop and allow at least one port open, you're unsafe. Dot.
Disable Remote DeskTop access, or forget thinking about security.
If you have experianced users, they'll find a way to use Remote DeskTop on other than default, but open ports.
If you have unexperianced users, the risk might be less, but keep in mind that these unexperianced users are subject to any kind of malware, which then becomes your problem ('cause it's programmed by experianced users, usually;-)
0

Featured Post

Four New Appliances. Same Industry-leading Speeds.

But don't take it from us.  The Firebox M370 is Miercom tested and Miercom approved, outperforming its competitors for stateless and stateful traffic throughput scenarios.  Learn more about the M370, M470, M570 and M670 and find the right solution for your organization today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Getting to know the threat landscape in which DDoS has evolved, and making the right choice to get ourselves geared up to defend against  DDoS attacks effectively. Get the necessary preparation works done and focus on Doing the First Things Right.
The well known Cerber ransomware continues to spread this summer through spear phishing email campaigns targeting enterprises. Learn how it easily bypasses traditional defenses - and what you can do to protect your data.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question