Windows XP, Belkin Wireless Router, PC Card and WPA

I have a belkin wirlerss router and I have upgraded the firmware for WPA support. I have installed the WPA patch from MS and I have upgraded the the driver for my pc card. However, I do not have the option to change to WPA in the properties for my wireless connection. Any ideas?
LVL 1
cebrooks03Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

stevenlewisCommented:
who makes the pc card?
0
cebrooks03Author Commented:
Belkin. I have the drivers for the PC card and the firmware for the router......
0
stevenlewisCommented:
you don't specify which models of router, and card but
http://web.belkin.com/support/kb/kb.asp?a=2806
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

cebrooks03Author Commented:
54g equipement, sorry about that. There is only one wireless router and pc card for the g line. The Belkin site is how I got started on this and after following there directions with downloads and ms's patch I don't have the WPA option on my adaptor properties as I should on my system. There is something not getting installed on the MS side I would think. I installed the firmware for my router and set WPA but can't get it set on my system.
0
stevenlewisCommented:
what shows up under Network Authentication  (the security mode)?
0
stevenlewisCommented:
also what shows up under Data encryption
0
cebrooks03Author Commented:
ether shared or open and ether one selected will get me Disabled or WEP under Data Encription.
0
stevenlewisCommented:
You don't get EAP? (under open)
also check your services and make sure the wireless zero config service is running, if not start it and put it on auto
http://support.microsoft.com/?kbid=815485
0
cebrooks03Author Commented:
Wireless zero is running in auto. nope, I don't get anything but WEP and disable under open....
0
stevenlewisCommented:
try uninstalling and reinstalling the patch
0
cebrooks03Author Commented:
No joy! I don't get this. I wonder if some software I'm running could be causing interference with the patch...... Maybe I should uninstall my pc card and reinstall it. What do you think?
0
stevenlewisCommented:
couldn't hurt
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cebrooks03Author Commented:
I now have a connection to my router but now I have a DNS problem. I'll get this one figured out. Thanks for the help.
0
stevenlewisCommented:
What do you have listed as your dns server for the pc card?
0
cebrooks03Author Commented:
On the wireless card I have nothing. No IP, No DNS, nothing. On my ethernet connection it works great.

0
stevenlewisCommented:
Do you know the ip of your router?
0
stevenlewisCommented:
I mean  the LAN ip
0
cebrooks03Author Commented:
I know what they are. Should I Statically set them?
0
cebrooks03Author Commented:
another problem I have is that I'm only connecting at 11mbps not 54....
0
stevenlewisCommented:
Yes, and use the router LAN interface as the dns server
0
cebrooks03Author Commented:
please explane what you mean by the router LAN interface. I'm not sure what you are telling me.
0
cebrooks03Author Commented:
I should also tell you that I'm not getting an ip address ether.
0
stevenlewisCommented:
You have two parts of the router, the WAN interface (the part that connects to your ISP) and the LAN interface (the part that your internal network connects to)
I have a wired d-link, but the principle is the same
my router connects to my dsl modem (this is the WAN interface)
and my machines connect to the LAN interface, in my case the ip is
192.68.0.1
so when I set my client ip's I use (for example my laptop)
192.168.0.10
mask 255.255.255.0
gateway 192.168.0.1
dns 192.168.0.1
0
stevenlewisCommented:
then to test it, from my laptop i ping
(from a prompt)
ping 192.168.0.1
and get a response, that way I know I can connect to my router
0
cebrooks03Author Commented:
Ok, I got it working. Turns out that the firmware upgrade on the router did not take completely. Once I re did the firmware upgrade everything worked as it should. Thanks for the help.......Chris
0
stevenlewisCommented:
Great! good luck to you!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.