• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 537
  • Last Modified:

Stylesheets: Notes item not found ...

I defined a style sheet in my application (in the shared resources -> stylesheet section of the designer). I then have a form that has the head section referencing these style sheets as follows (This is what the "view source in browser shows me"):
<head>
....
<link rel="stylesheet" type="text/css" href="/mm/mmonline.nsf/style.css" media="all" />
<link rel="stylesheet" type="text/css" href="/mm/mmonline.nsf/printlayout.css" media="print" />
<link rel="stylesheet" media="screen" title="main" type="text/css" href="/mm/mmonline.nsf/screenlayout4.css" />
<link rel="alternate stylesheet" media="screen" title="optional" type="text/css" href="/mm/mmonline.nsf/screenlayout3.css" />
...
</head>

The path is correct to me but it does not seem to work and the error from the server logs is :
...Note item not found. However if this is running on local it works fine strangely to me. So is there something I need to make sure of on my server. (Domino 5.0.5 )

thanks
-jay
0
jdembare
Asked:
jdembare
  • 2
  • 2
  • 2
  • +2
1 Solution
 
qwaleteeCommented:
Try putting each of the stylesheet URLs in your browser address bar to see which one os causing the problem (you do have four of them after all).

Also, try making a new copy of the database, see if the copy has the problem.

And, try opening each style sheet, making an innocuous edit (add some white space), change the sheet's comment, and save the style sheet.
0
 
CRAKCommented:
If you remove those lines, does the error dissapear? It could be a computation elsewhere that fails!
Or try to identify if all lines fail, or just a specific one.

This db, mmonline.nsf, is it the same as the one you have on local? Is it accessible for webusers (anonymous and/or authenticated)?
0
 
HemanthaKumarCommented:
It is your href path in the link tag which is messing this up. Make sure the mmonline.nsf is in mm dir and it is located below data directory of the server.

Also if the css files are within current db then reference it without any path.

~Hemanth
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
jdembareAuthor Commented:
Thanks all for the comments, for some reason it seems that it was due to the domino server version coz i put the database on dominino 6.x server and it works fine. I guess it's because I working on notes 6 client but was running the application of domino 5.

-jay
0
 
qwaleteeCommented:
Yes, that would explain it.  R5 does not support style sheets.  R6 sets up the stylesheets the same way it sets up pages.  It creats a design elemnt, with flags C34Q.  But stylsheets have an additional flag, I think it is $.  R6 understands this, and lokos at it as a stylesheet instead of a page.  R5 just thinks it is a page.  To send page content, it needs the design fields (Note Items) named $Body and $HTMLCode.  Stylesheets don't have these fields; they have $FileData, which is a rich text field with he style shet file embedded in it.  So, when the R5 serevr attempted to display the "page," it complained about the missing Notes Item.

You can get around this!

Create a new page named style.css, and import/paste teh CSS file txt into it.  In Page properties, change ON WEB ACCESS from Notes type to HTML.  (Technically, you shoudl choose OTHER and type, I think, text/css, but HTML will work just as well inmy experience).
0
 
HemanthaKumarCommented:
You can overcome that easily by importing style sheet into imageresources section as .css file and used it both in R6 and R5.
0
 
madheeswarCommented:
What I done in R5 is to save css code into a page and save it as .css

That worked for me.

And if the code is in the same db, then no need to refer it with a path.

below is the code which I used.
in HTML HeadContent event of the form:
DBPath:=@ReplaceSubstring(@Subset(@DbName; -1);"\\" : " "; "/" : "+");
"<LINK rel=\'stylesheet\' type=\'text/css\' href=\'/"+DBPath+"/TestStyle.css\'>"

all the links on your page/form/view should not have <font> tags.
0
 
jdembareAuthor Commented:
Thanks  qwaletee, it worked perfectly. Must also give credit to madheeswar for being in the same line as q. HemanthaKumar, it seems like I couldn't simply import any other file that is not of type gif,jpg etc (basically) image format so got stack there otherwise I see the idea and would have been much neater. Thank guys

-jay
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 2
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now