php as cgi script

Hi!

Do someone know how can I configure the apache web server or the php to run a php as a cgi script?

When I try this line in php code,
#!/usr/local/bin/php
I get this error on my log
Premature end of script headers:
/www/cgi-bin/pruebacgi.php

and
When I try  this line,
#!/usr/local/bin/php -q
I get it:
malformed header from script. Bad header=       php
[options] -r <cod
e>: /www/cgi-bin/pruebacgi.php
I hope someone can help me!

Thanks in advance,
Kisses
SherlyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

duerraCommented:
Make sure lines like this are in your http.conf:

   ScriptAlias /php/ "usr/local/bin/"  
   Action application/x-httpd-php "/php/php.exe"

   AddType application/x-httpd-php .php
   AddType application/x-httpd-php .html
   AddType application/x-httpd-php .htm


This will make PHP run in CGI mode.
0
duerraCommented:
Make sure lines like this are in your http.conf:

   ScriptAlias /php/ "usr/local/bin/"  
   Action application/x-httpd-php "/php/php.exe"

   AddType application/x-httpd-php .php
   AddType application/x-httpd-php .html
   AddType application/x-httpd-php .htm


This will make PHP run in CGI mode.
0
SherlyAuthor Commented:
hello duerra,
thanks for reply!

Well I have the apache 1.3.28 and the php 4.3.3 on Red Hat Linux 7.3

I don't have the lines you said me. I have the lines below. So do I need to add the two firsts lines? (   ScriptAlias /php/ "usr/local/bin/"    Action application/x-httpd-php "/php/php.exe")


   #
    # AddType allows you to tweak mime.types without actually editing it, or to
    # make certain files to be certain types.
    #
    AddType application/x-tar .tgz
    # The following is for PHP4 (conficts with PHP/FI, below):
    <IfModule mod_php4.c>
      AddType application/x-httpd-php .php4 .php3 .phtml .php .wml
      AddType application/x-httpd-php-source .phps
    </IfModule>
   
     #The following is for PHP3:
    <IfModule mod_php3.c>
      AddType application/x-httpd-php3 .php3 .wml
      AddType application/x-httpd-php3-source .phps
    </IfModule>
   
     #The following is for PHP/FI (PHP2):
    <IfModule mod_php.c>
      AddType application/x-httpd-php .phtml
    </IfModule>


    #
    # ScriptAlias: This controls which directories contain server scripts.
    # ScriptAliases are essentially the same as Aliases, except that
    # documents in the realname directory are treated as applications and
    # run by the server when requested rather than as documents sent to the client.
    # The same rules about trailing "/" apply to ScriptAlias directives as to
    # Alias.
    #
    ScriptAlias /cgi-bin/ "/www/cgi-bin/"

    #
    # "/www/cgi-bin" should be changed to whatever your ScriptAliased
    # CGI directory exists, if you have that configured.
    #
    <Directory "/www/cgi-bin">
        AllowOverride None
        Options None
        Order allow,deny
        Allow from all
    </Directory>

</IfModule>
# End of aliases.

    #
    # AddHandler allows you to map certain file extensions to "handlers",
    # actions unrelated to filetype. These can be either built into the server
    # or added with the Action command (see below)
    #
    # If you want to use server side includes, or CGI outside
    # ScriptAliased directories, uncomment the following lines.
    #
    # To use CGI scripts:
    #
    #AddHandler cgi-script .cgi

Thanks a lot!
I appreciate your help.
Sherly
   
0
duerraCommented:
Correct.  Except put a slash in front of /usr/.  I missed that the first time:

ScriptAlias /php/ "/usr/local/bin/"    
Action application/x-httpd-php "/php/php.exe"

Also, you may not need the quotes.  I'm used to Windows configuring of PHP, so the Linux version may not require them.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Languages and Standards

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.