XP sharing, user name problem

I have a peer-to-peer network of winXP computers.
When I try to access a particular computer I get the "Connect to [computername]" dialog where I need to enter a username and password.
The problem is that the User name part is greyed and the option is "[computername]\Guest"

I want to enable access to only those users who have an account on that computer. When the above dialog appears I want the user to input his/her user name and password to gain access to the share.

Many Thanks,
Rob
MemranAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

chicagoanCommented:
make sure the guest accounts are disabled and try:

 Start => Programs => Accessories => Windows Explorer and drop down the Tools menu and select ‘Folder Options’. Select the View tab
Go to Advanced Settings
Clear  "Use Simple File Sharing"

By default, simplified sharing is enabled on a WinXP if the computer is not a member of a domain. Simplified sharing lets you easily share folders with everyone on your workgroup or network and make folders in your user profile private. However, if simplified sharing is enabled, you cannot prevent specific users and groups from gaining access to your shared folders. If you disable simplified sharing, you can allow specific users and groups to gain access to a shared folder; those users must provide a password to gain access to your shared folder.

If simple file sharing is enabled, you see the Simple File Sharing user interface rather than the classic Security and Sharing tabs. This new user interface is implemented by default in  XP Home Edition and XP Pro if you are working in a workgroup. If you disable simplified sharing, the classic Security and Sharing tabs appear and you can specify which users and groups have access to shared folders on your computer.

(You cannot disable simplified sharing in Microsoft Windows XP Home Edition)

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MemranAuthor Commented:
Many thanks :)
Problem solved!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.