?
Solved

Getting Remote Desktop Connection to work on a LAN

Posted on 2003-11-29
20
Medium Priority
?
117,134 Views
Last Modified: 2011-08-18
I have been trying to get remote desktop connection to work on my LAN but everytime I try to connect I get the following error message

"The client could not connect to the remote computer.

Remote connections might not be enabled or the computer might be too busy to accept new connections. It is also possible that network problems are preventing your connection."

I tried diabling my firewall totally, made no difference.

What am i missing?
0
Comment
Question by:mkandre
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
20 Comments
 
LVL 1

Author Comment

by:mkandre
ID: 9843300
By the way I'm running XP home edition on one system and ME on the other. Both systems are curently available on the LAN to share resources.
0
 
LVL 1

Author Comment

by:mkandre
ID: 9843302
By the way I'm running XP home edition on one system and ME on the other. Both systems are curently available on the LAN to share resources. And Remote Destop Connection is installed on both.
0
 
LVL 26

Accepted Solution

by:
Soulja earned 100 total points
ID: 9844555
Remote desktop is not available for Windows ME and XP Home Edition. What you probably have installed on your computers is the client piece to Remote Desktop that allows you to connect to XP Professional Computers and Windows Terminal Servers.

0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 1

Author Comment

by:mkandre
ID: 9847847
thats just so wrong; but luckily i found a way around that, with netmeeting. It has remote desktop sharing, so my roblem is solved thanks any way or trying
0
 
LVL 26

Expert Comment

by:Soulja
ID: 9851278
"thats just so wrong"

Do you mean my answer is wrong? or It's wrong that it's not available for ME and XP Home Edition?
0
 
LVL 1

Author Comment

by:mkandre
ID: 9875306
It means your answer is fine, I just wish there was a better solution.
0
 
LVL 1

Expert Comment

by:sendtojp
ID: 10857855
That sucks that you gave a 'C' grade.
:(

Hey how can I get started with Remote Desktop, I will give 500pts of 'A' grade.  I am using the Pro edition, also I read I acticle in a magazine which says you can download the componets from Mircosoft to enable Remote Desktop on Home Editions, I wish I can remember where.

Also is it possable to try Remote Desktop on the same machine?
0
 

Expert Comment

by:Inspire212
ID: 10951399
You can download the client to install on your PC with an older version of windows at http://www.microsoft.com/windowsxp/pro/downloads/rdclientdl.asp  I have had clients use this and it works great!

Hope this helps
0
 

Expert Comment

by:Costasd
ID: 10970652
Hi

I will give 500 points to whoever can help me solve my problem.

I have XP Pro on my PC and XP Home on my laptop. I am tryng to access my PC with XP Pro from my laptop via Remote Desktop connection.

I am getting the following message to whatever i try.
"The client could not connect to the remote computer.

Remote connections might not be enabled or the computer might be too busy to accept new connections. It is also possible that network problems are preventing your connection."

I am on a wireless Lan

What i have attempted so far:
- Wehnt into Control Panel/System/Remote/Select Remote Users/ and chose remote users. What i absically did what set up a new account for this purpose.
- I allowed access through firewall on Remote Desktop Port 3389
On XP Home machine staretd remote Desktop Application.
Where its says computer, i tried using IP Address, and the XP Pro pcs name. No Luck
Udername i tried using The account name that is using the WIn XP machine at that moment, and also teh new account created. NO LUCK

Also when i click on the arrow next to Computer It says " Browse For More..." When i click on that it has an option called WorkGroup, but when i choose taht its brings up a message the domain/workgroup does not contain any terminal servers.

IM SERIOUSLY STUCK TO WHAT I AM DOING WRONG.
500 POINTS TO WHOEVER CAN HELP, POSSIBLY MORE THE QUICKER I CAN USE THIS SERVICE.

THANKS
0
 

Expert Comment

by:robdaugherty
ID: 10979925
To enable remote desktop, right click the "My Computer" icon, go to the tab labeled "Remote", check the box next to "Allow Remote Desktop...", then add whichever users you'd like using the button to the right of the Remote Desktop section.
0
 
LVL 2

Expert Comment

by:Hofftek
ID: 11011736
Make sure you have XP's software firewall turned off on both machines lan connections.  I know that has burned me more than a few times.
0
 

Expert Comment

by:CDT40-10
ID: 11323946
all you have to do is to enable the port for the remote desktop, that's all.

http://www.microsoft.com/windowsxp/using/networking/expert/russel_02January14.mspx

later dudes.
0
 

Expert Comment

by:slingeman
ID: 11494102
Hello,

Sometimes I can connect to the remote computer, sometimes I get the "The client could not connect to the remote computer" error. It was fine four hours ago and now I can't connect. Both machines are XP Pro and the remote is using ICF ONLY with RDP port 3389 enabled. Is ICF causing this?  Both are on a cable connection and I can't telnet the remote either.

Thanks
0
 

Expert Comment

by:slingeman
ID: 11497910
I meant RDP on TCP 3389. But you knew that...didn't ya.
0
 

Expert Comment

by:eggy_b
ID: 11698581
make sure that you have admin rights to both computer. On the computer you are trying to connect to do this:
1) Right click on My Computer.
2) Click on Properties
3) Click on Remote Tab.
4) Make sure Remote Desktop is checked.
5) Click on Select Remote User and add the user you have created to allow acces through Remote Desktop.
6) OK out of it.

Retry Remote Desktop from Client computer.

Rgds.
0
 

Expert Comment

by:nandosit
ID: 12603179
I've had all the same problems as the above.

I realised that pinging the machine wasn't returning the correct IP so my dns cache must be screwy.

In the end I did ipconfig /flushdns from the command prompt and all my problems melted away.
0
 

Expert Comment

by:npny
ID: 12636163
I am having a similar problem.

Win XP Pro running on desktop and laptop.  Trying to use RDC to connect to desktop from laptop over internal Lan.  When I use the drop down menu in Remote Desktop Connection to 'Browse for more...' my workgroup shows up, but when I try to expand out the work group I get the "The ... domain/workgroup does not contain any Terminal servers." error message.  

Alternatively, if I just type in the computer name of the desktop, I make it all the way to the login prompt with username and password.  When I enter the user name and password for the desktop, I get the following error: "Unable to log you on because of an account restriction."  I have tried logging on with the correct username but wrong password, and I get a logon message telling me that the username and/or password are incorrect.  I am using a different username and password on the desktop, so the RDC must be authenticating the correct username and password from the desktop, but then running into an account restriction problem with that particular user.  I have verified the user on the desktop, however, it is a member of the Remote Desktop Connection users group.  I have also checked it through 'my computer' --> properties --> remote --> Select Remote Users, and it's there (same thing).  

I have attempted to add \\laptop\user as a permitted user via the RDC menus, (or via 'my computer' --> properties --> remote --> Select Remote Users if you prefer) but I get stuck at locations - it won't look for users beyond the local machine because there is no server, and if I just type it in it looks for \\desktop\laptop\user, which is ridiculous.

The RDC overview on Windows help doesn't say anything about needing a terminal server.

In short, two xp pro machines, both with RDC properly installed and authorized (my computer --> properties --> Remote --> allow...), user properly set up as an authorized remote desktop user, but there are two problems: 1) RDC on laptop won't browse beyond local machine to find the desktop (yes the lan is configured properly, I can browse shared folders from and to both machines, and I have verified that the remote desktop connection 'exception' is authorized to port through the ICF on both machines), or in the alternative 2) typing in the name of the desktop allows me to initiate a connection and, presumably, authenticates the username and password, but gets stuck on some user restriction, which I have not been able to identify.
0
 

Expert Comment

by:npny
ID: 12636316
Figured it out.  Somehow I missed a very obvious requirement: the user set up for remote access may not have a null password.  http://support.microsoft.com/default.aspx?scid=kb;EN-US;q303846
0
 
LVL 1

Expert Comment

by:james_daley
ID: 14159474
Hi,

If setting up RD, ensure the following:
1. Make sure RD is installed on your system or download it from the Microsoft website.
2. Set your IP address if you are using a router.
3. Forward the TCP 3389, (or whatever port you changed in the regisrty. To change the port visit http://support.microsoft.com/default.aspx?scid=kb;en-us;306759).
4. Forward the port to your computers IP.  (if you have a router).
5. Make sure your windows user account has a password.
6. Enable Remote Desktop in Control Panel->System->Remte Desktop
7. Configure your firewall for the TCP port.
8. Connect locallly (using the local ip:the port. eg 10.0.0.55:3377) or remotely (using the external ip. eg.134.234.234.234:3377)

Thats it
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes you might need to configure routing based not only on destination IP address, but also on a combination of destination IP address (or hostname) and destination port number. I will describe a method how to accomplish this with free tools. …
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question