File Sharing between Wired and Wireless Computers in a Home Network

I had a Desktop (running Win XP Pro) with Cable Modem. I recently purchased two laptops (both with XP Pro) and D-Link DL515 802.11b router. I connected the cable modem to the router and from the router to my dekstop. I then setup wireless cards on both my laptops. Everything works good. I am able to access the Internet from all the three machines.
The only problem is with file sharing. I unable to setup file sharing between the three computers. I am able to access one laptop from another and I am able to access the two laptops from my desktop. But I am UNABLE to access my desktop computer from both the laptops. All three machines have local IPS 192.168. and are part of the same workgroup MSHOME (the default one) If from the laptop, I go to My Network Places and View Workgroup Computers, I am able to see my desktop. But when I double click on the computer name, it says the domain MSHOME is not accessible. What could be wrong and what do I need to do to resolve this issue.
Thanks
Sankar030999Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

stevenlewisCommented:
Run local security policy editor from control panel admin tools and set the local policy, Network Access: Let everyone permissions apply to anonymous users, to enabled and make sure guest account is enabled


also make sure NetBIOS over tcp is enaled (it is disabled by default)
Enable NetBios over TCP/IP in WIndows XP

Step 1: Turn On NetBIOS over TCP/IP

Click Start, click Control Panel, and then click Network and Internet Connections.

Click Network Connections.

Right-click Local Area Connection, and then click Properties.

Click Internet Protocol (TCP/IP), and then click Properties.

Click the General tab, and then click Advanced.

Click the WINS tab.

Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.

Click Close to close the Local Area Connection Properties dialog box.

Close the Network Connections window.

Step 2: Start the Computer Browser Service

Click Start, right-click My Computer, and then click Manage.

In the console tree, expand Services and Applications.

Click Services.

In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.

Close the Computer Management window.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Sankar030999Author Commented:
Hi,
Thanks for the reply. I did all the steps you mentioned. But it did not work. Then as a last attempt, I just simply disabled the Firewall (the default windows firewall) for the LAN connection in my desktop. It then worked. I was able to access my desktop from my laptops. I have no clue as to why the firewall would block the access from my laptops. What's the reason for it not to work with the firewall enabled? Is there any way to have it work properly even with the Firewall enabled. Let me know. If you don't know, its fine. I will anyway go ahead and close the question and give you the points.
Thanks
0
stevenlewisCommented:
The built in firewall on XP is lame, get zonealarm
www.zonelabs.com
you can configure that to allow LAN traffic, but protect your from unwanted internet traffic
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.