server on network only accessable to client machines

I have a network consisting of two computers on file / printer shareing.  Installed on my XP machine (master) is a web server.  I can only access my web server from the client using ip 192.168.0.1 on the XP machine running the web server, I cannot access it, localhost, 127.0.0.1, 192.168.0.1 and my true ip address 24.102.x.x can not be used to access the page, they all return a error 500 internal server error.

I canno't figure out what is causeing this, can someone please help make the server accessable from within itself.
atapi103Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

qwaleteeCommented:
If I had to guess, the machine in an ICS machine, and the server is bound only to the "inside" interface.  But the default local interface is for the outside (internet) connection.
0
atapi103Author Commented:
I am new to networking can you please help me to understand what I need to re-configure so that my xp machine, can access it's own server using localhost.

It is true I am shareing an internet conection, my XP machine is aparently acting as a gateway so i am told.
0
tatoonCommented:
I'm not sure about the cause. But from my experience, if you use the localhost address (127.0.0.1) in network stuff sometimes works and sometimes dont, I dont know why, so I always use the network address 192.168.0.x, this one works always.

The other point, if you use your public ip address from inside your network, it wont work, since your computer cant find it, the public ip is to be used by computers outside your network. So you should be doing your tests with the 192.168.0.x ip and the people you want to visit your website (from the internet) should use your public ip.

About the error that cant find your website... are you behind a router or firewall? Maybe you have the port 80 closed or is not directly redirected to your computer. Even if you are the gateway I think you have to specify in the proxy/routing program you are using that the port 80 is exclusively for your computer.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

chicagoanCommented:
If you're getting an HTTP 500 error you are contacting the web server, this is not a networking issue, so don't go fiddling with your network settings.

Try changing the binding in your server to ALL IP in the internet configurating console.

Disable "friendly" error messages in internet explorer and check the event log on the server to get more information about what the error was and post what you find here.
0
lrmooreCommented:
Have you enabled the XP firewall on the external interface?

0
sn1xipelookCommented:
Thanks for all the replys, strange why localhost dont work, but I can settle with 192.160.0.x from my networked client, since it worked when I tryed.  Unfortunate though my localhost isnt accessable from the server itself.  I did try my true ip 24.102.x.x and as you said, that dont work either.

I will have to love with it i guess.  But I thank all who helped.
0
sn1xipelookCommented:
Thanks for all the replys, strange why localhost dont work, but I can settle with 192.160.0.x from my networked client, since it worked when I tryed.  Unfortunate though my localhost isnt accessable from the server itself.  I did try my true ip 24.102.x.x and as you said, that dont work either.

I will have to love with it i guess.  But I thank all who helped.
0
sn1xipelookCommented:
There is no like to accept a comment as an answer, I wish to accept tatoons answer.  Any guidence?
0
lrmooreCommented:
Log back in as your other identity - atapi103, and you will be able to accept an answer...
0
sn1xipelookCommented:
ok I logged out and cleared my cache and loged back in, but still no link to accept an answer.  It only says "Comment from tatoon
Date: 11/30/2003 04:29AM PST" and then beside that it says comment, no accept.  I can verify I am logged in at top right.

0
atapi103Author Commented:
I must apologize, I just noticed I was using my second account to post the question, and that is why I was unable to accept any comments.
0
atapi103Author Commented:
Please remove my sn1xipelook account.  I was unaware of this rule but thanks for informeing me.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.