Solved

can't launch several applications because of shared library error and can't find into on Carbon Lib anywhere

Posted on 2003-11-30
5
1,291 Views
Last Modified: 2012-08-13
for Yahoo Messenger:
the application "(null)" could not be launched because of a shared library error: "4<Yahoo!Messenger><CarbonLib><CFMPriv_CarbonSound><>"



for MS Word:
the application "Word" could not be launched because of a shared library error: "2<YMicrosoftWord><CarbonLib><CFMPriv_CarbonSound><>"

for Explorer:
the application Explorer" could not be launched because of a shared library error: "<MacIE Carbon(Release)><CarbonLib><CFMPriv_CarbonSound><>"


this might also apply to PowerPoint and Excel.

I can launch Safari and Netscape, but after i get into mediabistro.com and try to get into personals, Safari quits, Netscape opens another window to download (can't remember, and if i check, this will be lost!)


0
Comment
Question by:leslielle2003
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 30

Accepted Solution

by:
weed earned 168 total points
ID: 9846305
Sounds like you have an incomplete installation of either the OS, or your Apps. Sounds like youre running word via classic mode too. What happens if you boot to OS 9 before running it? MS products are notorious for using loads of goofy libraries which are probably missing. Reinstall those apps and see if that helps.
0
 
LVL 2

Assisted Solution

by:macmend
macmend earned 166 total points
ID: 9865789
It is likely that the version of OS 9 you are running has not got an uip to date version of carbon lib installed or if these are all from OS X then THE CARBONB LIB YOU HAVE IS CORRUPT OR OUT OF DATE.

Try launching in OS 9 and running software upodate from the control panels, and/or software update from the prefernces in OS X
0
 

Assisted Solution

by:addihetja
addihetja earned 166 total points
ID: 9909179
I have seen this error on computers in a lab that do _not_ have OS 9 installed. When I ran fsck in single-user mode (command-s on boot) it displayed errors it couldn't repair. I usually use DiskWarrior to fix errors on hard drives, but since this was a lab machine I did a complete reinstall of the OS.

HTH
0

Featured Post

Simple, centralized multimedia control

Watch and learn to see how ATEN provided an easy and effective way for three jointly-owned pubs to control the 60 televisions located across their three venues utilizing the ATEN Control System, Modular Matrix Switch and HDBaseT extenders.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

A common question or need, when setting-up a new Mac for someone would be to make all of the applications, installed, available from the dock. Many people often do not realize an application is installed unless it is in the dock. Creating a custo…
There is a security feature on iOS devices that is nearly impenetrable when it has been activated.  This article will provide some possible solutions as well as necessary steps to take to ensure you do not end up with a locked device.
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question