Complete DNS Config Needed

I have spent over a week attempting different configurations and I have gotten close but just can't seem to grasp the Brass Ring... Instead of tryint to fix my patched together attempts and make them work, I am more willing to pay the points for a cut and paste configuration. Here are the specifics behind my network:

Primary Domain Name:
abcde.net

4 Hosts : IP
   ls01.abcde.net   1.2.3.51
   ls02.abcde.net   1.2.3.52
   ls03.abcde.net   1.2.3.53
   ls04.abcde.net   1.2.3.54

ls01 is also known as ns1.abcde.net and is Master NS
ls04 is also known as ns4.abcde.net and is Secondary NS

MX should point to mail.abcde.net @ 1.2.3.51

Also add in the following secondary and tertiary domains to the mix so they resolve correctly
   abcde.com
   abcde.org

Assume there is an FTP and WWW on 1.2.3.51 for all three domain names
Assume the contact name for any zone is dnsadmin

I only wish to have the Primary NS Conf files... once I have this working I will worry about the Seconday... If you are feeling industrious, feel free to include for both...

If you need more Info, I will be available to answer... I need this rather quickly since I have already registered the ns1 and ns4 boxes and have the abcde.xxx domains pointing at them. Nothing like being in a rush.
Thanks in advance!
-greg
LVL 12
Gregory MillerGeneral ManagerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

td_milesCommented:
OK, you want a cut/paste job, here it is:

Append this to your "/etc/named.conf" file:
=============
zone "abcde.net" IN {
        type master;
        file "zone/abcde.net";
        allow-transfer {192.168.144.0/24; localhost; };
        allow-query { any;};
};
=============

When you setup the secondary NS, you'll need to add the IP address into the "allow-transfer" field, so that it can do the zone transfer to sync. I run my DNS on a NAT'ed 192.168.144.x address, hence why mine has this. I left it in, so that there was something in there.


Then create the zone file "/var/named/zone/abcde.net":
=============
$TTL 86400      ; 1 day
@               IN SOA  ns1.abcde.net. postmaster.abcde.net. (
                                2002070901          ; serial
                                600     ; refresh (3 hours)
                                3600       ; retry (1 hour)
                                604800     ; expire (1 week)
                                86400      ; minimum (1 day)
                                )
                        NS      ns1.abcde.net.
                        NS      ns4.abcde.net.
                        MX      10 mail.abcde.net.
$ORIGIN abcde.net.
ns1                   A       1.2.3.51
ns4                   A       1.2.3.54
ls01                  A       1.2.3.51
ls02                  A       1.2.3.52
ls03                  A       1.2.3.53
ls04                  A       1.2.3.54
www                   A       1.2.3.51
ftp                   A       1.2.3.51
mail                  A       1.2.3.51            
=============

Replicate the above for the .com & .org (you'll need to do both parts). Restart named and see how you go. I'm assuming that you have the default config locations and stuff. I haven't included all of the default stuff that goes in named.conf that gives locations and other default options. If you DO need this, let me know.


If you haven't found it already, a good reference is:
http://www.tldp.org/HOWTO/DNS-HOWTO.html


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gregory MillerGeneral ManagerAuthor Commented:
Thank you... The HOWTO you referenced was the nail that sealed the coffin. DNS is live on one server and the second is just quivering in anticipation. I, on the otherhand need sleep... It is amazing how a missing "." can cause so much grief.

I actually had pretty much the same file as you had listed but with one exception. I negelcted to put the period "." after the FQDN on the SOA line. Oh well... not bad for never looking at DNS configurations before. The points are yours...

Thanks Again...
-Gregory Miller
AGBSM, LLC
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Languages and Standards

From novice to tech pro — start learning today.