Request.servervariables("LOGON_USER") gives an empty string on client machines with Windows XP

IIS 5.0 is installed on windows 2000 web server. The client machines are using windows XP. Request.servervariables("LOGON_USER") gives an empty string on client machines. but this is working on the server. "Anonymous Access" is unchecked. "Integrated Windows Authentication" is checked in IIS.

Any idea?
ManSreeAsked:
Who is Participating?
 
c_swankyCommented:
I've only seen this if  "Anonymous Access" is CHECKED.

Just to make sure, go into IIS and navigate all the way down to the FILE LEVEL, open the properties for the .asp file (NOT the folder), check the File Security and make sure the Anonymous Access" is unchecked there.

Do you have multiple severs?


0
 
ManSreeAuthor Commented:

"Anonymous access" is unchecked for the asp file.

We do have multiple servers. But we have only one web server.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
c_swankyCommented:
Have you tried creating a simple .asp like this?

<%
Response.Write("AUTH_USER" & Request.ServerVariables("AUTH_USER") & "<br>")
Response.Write("LOGON USER" & Request.ServerVariables("LOGON_USER") & "<br>")
Response.Write("REMOTE_USER" & Request.ServerVariables("REMOTE_USER") & "<br>")
%>

When calling this page are you getting any errors on the CLIENT'S machine?

Also you can check the following setting on the CLIENT’S browser:
Tools > Internet Options
Click the “Security” Tab
Click the “Custom Level” button
Scroll to the very end (look for “User Authentication”)
What’s is this set to?
0
 
ManSreeAuthor Commented:

I found out the problem. The server was not joined to the domain properly. I had the server joined the domain and do some small tricks, which solved the issue.

Thanks a lot for all your help!!!
0
 
c_swankyCommented:
Cool!

Just for future ref, were you getting an error on the client's machine when attempting to access the page? if so what was it?
0
 
ManSreeAuthor Commented:
Since "Anonymous access" was unchecked, the user is prompted for User id & password.

The client's browser setting : Automatic logon only on Intranet zone is selected.
0
 
c_swankyCommented:
ManSree - Please don't forget to close this question now that you have figured out the problem.
0
 
ManSreeAuthor Commented:
How do I close this question?. I'm new to this site.
0
 
ManSreeAuthor Commented:
Pls close this question.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.