Solved

connecting my network to the internet through cisco router1605

Posted on 2003-11-30
4
444 Views
Last Modified: 2010-04-11
i would like to know how i can connect my 2000 server, winxp &win200pro using  as a workstation through cisco router 1605 with 2 ethernet port to the ethernet using my cable ethernet provided by my ISP, i need help on the configuration on the router
0
Comment
Question by:nnawusu
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 7

Accepted Solution

by:
NicBrey earned 250 total points
ID: 9848746
You will need a small hub or switch to connet the server and workstations to. Also connect the switch to the one ethernet interface of the router and the modem to the other.

You will need to configure NAT on the router to access the internet.
A basic configuration will look something like this.


interface ethernet 0                                     <---inside interface
ip address  192.168.1.1    255.255.255.0
ip nat inside

interface ethernet 1                                                                  <--- outside interface
ip address <address and mask asigne by ISP>
ip nat outside


access-list 1 permit  192.168.1.0   0.0.0.255                             <--- access list defining internal network to NAT

ip nat inside source list 1 interface ethernet 1 overload
ip nat inside source static tcp 192.168.1.10  25  ethernet 1  25    <--- port forwarding for SMTP traffic - assuming 192.168.1.10 is SMTP server adress

ip route 0.0.0.0  0.0.0.0  ethernet 1                                           < --- default route



0
 

Author Comment

by:nnawusu
ID: 9854164
the ip address for the ISP is going to be dynamic
0
 
LVL 7

Expert Comment

by:NicBrey
ID: 9856731
That's not a problem.

On your outside interface, you just configure the line:
ip address dhcp

Will get IP address from cable provider. The port forwarding and NAT configuration I gave above is not bound to the IP address, but to the outside interface (ethernet 1).
0
 

Author Comment

by:nnawusu
ID: 14222145
I have win2003 server(active directory), xp workstation connecting to the internet via netgear router with no problem,, I am receiving error when trying to connect to the domain, do I have to configure the win2003 using static ip address with no dhcp server?
0

Featured Post

Save the day with this special offer from ATEN!

Save 30% on the CV211 using promo code EXPERTS30 now through April 30th. The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
replacing 2811 to ISR 4331 2 48
Changing VLAN information 3 36
Applying Computer Settings 12 95
Advice on using wifi connection in Hotel with our iPhone 18 80
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question