Solved

Powerbuilder App Crashing on Tecra 8000

Posted on 2003-12-01
6
304 Views
Last Modified: 2013-12-26
Hi

I have an app created in version 7.0.3 of Powerbuilder, connecting to an Oracle DB. The problem I have is that when I deploy the app to a Toshiba Tecra 8000 it crashes (it seems to be when the mousemove event fires). The same app running on a Compaq desktop does not crash at all. In the mousemove event I am calling SDK code to create tooltips (USER32.DLL). I thought it may be a Service Pack issue so now the two machines have Windows 2000 Service Pack 4 but it is still happening.

The error says about "instruction at 0x77fcc4ea referenced memory at 0x001eb4b5. The memory could not be read"
 
Sorry if this is vague but I'm at a loss as to what to try now, does anyone have any ideas?

Thanks
Ron
0
Comment
Question by:maran_software
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 8

Accepted Solution

by:
gajender_99 earned 250 total points
ID: 9849478
if you have powerbuilder on that machine try rebuilding it on the toshiba machine
0
 

Author Comment

by:maran_software
ID: 9849739
Thanks for the suggestion. The app still crashes but without the memory messages mentioned above. I tried to debug it, the first time I tried it PB itself crashed, subsequent tries and it went through fine with no crashes?!

Any other ideas?

Thanks
0
 
LVL 6

Expert Comment

by:DaniPro
ID: 9850336
do you have other sofware like .NET or resident software installed in your pc?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:maran_software
ID: 9850902
Yes, as well as Powerbuilder I have VB .NET 2003 installed.
0
 
LVL 6

Expert Comment

by:DaniPro
ID: 9851038
I have the same problem but only when I retrieve row on my DW.
I have solved my problem inserting a row in the retrieverow event of my DW.
I think that PB 7 and .NET don't work very well together on the same PC.
0
 

Author Comment

by:maran_software
ID: 9851522
Thanks, the problem I have occurs after there are rows retrieved into the datawindow. The strange thing is that the exe works o.k on the desktop with .NET installed but when the same files are used on the laptop it doesn't work.
0

Featured Post

Enroll in June's Course of the Month

June’s Course of the Month is now available! Experts Exchange’s Premium Members, Team Accounts, and Qualified Experts have access to a complimentary course each month as part of their membership—an extra way to sharpen your skills and increase training.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Update (December 2011): Since this article was published, the things have changed for good for Android native developers. The Sequoyah Project (http://www.eclipse.org/sequoyah/) automates most of the tasks discussed in this article. You can even fin…
Jaspersoft Studio is a plugin for Eclipse that lets you create reports from a datasource.  In this article, we'll go over creating a report from a default template and setting up a datasource that connects to your database.
The viewer will learn how to use NetBeans IDE 8.0 for Windows to connect to a MySQL database. Open Services Panel: Create a new connection using New Connection Wizard: Create a test database called eetutorial: Create a new test tabel called ee…
The viewer will learn how to use and create new code templates in NetBeans IDE 8.0 for Windows.

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question