Solved

RPM dependency - sorry guys.

Posted on 2003-12-01
10
775 Views
Last Modified: 2013-12-15
Hi,

  I am trying to install foobillard (http://foobillard.sunsite.dk/) onto my laptop.  As per usual ;-) I have a dependency problem when installing the RPM.

  I have Mandrake 9.1 running very nicely on an Acer TravelMate 420.
  It has an ATI Radeon mobility 7500 graphics card
  (not sure if any other info is relevant)

  I've downloaded both the GLUT and SDL binary RPMs and get the same problem for both (note that I'm not clear on which I actually need).

  rpm -Uvh foobillard-2.9-1.i586.rpm

results in:

error: failed dependencies:
        libGLcore.so.1   is needed by foobillard-2.9-1

Similarly, for the SDL version I get:

error: failed dependencies:
        libGLcore.so.1   is needed by foobillard-2.9-SDL

  I've had a google and found that libGLcore.so.1 can be provided from an NVIDIA package (but I don't have an NVIDIA card).  I don't believe that this only works on NVIDIA (does it?).

  So, the question...

  What do I need to get in order to succeed with the installation?
0
Comment
Question by:jimmack
  • 4
  • 4
  • 2
10 Comments
 
LVL 9

Assisted Solution

by:svenkarlsen
svenkarlsen earned 50 total points
Comment Utility
Jim,

sorry you haven't got any replies, - I'm not much into that application, but I suggest you try the FAQ on their site. As for your NVIDIA problem, their answer is:

Q: I have no NVIDIA Card but the compiler complains about some _NV functionts

A: Some standard gl.h files have all the extensions defined, which one can think of - even if the driver libs dont support them.
To disable NVIDIA features by hand do a:
 ...$ configure --enable-nvidia=no
before compiling.

This probably means that you will have to compile a pkg in order to install it, unless you can find another RPM which doesn't require the lib.


Kind regards,
Sven
0
 
LVL 20

Expert Comment

by:Gns
Comment Utility
CC Sven... It seems the binary rpms provided are built specifically for nvidia... Use the source rpm instead.

rpm -rebuild <source rpm>
rpm -ivh <just built package>
might work OK for you.

-- Glenn
0
 
LVL 15

Author Comment

by:jimmack
Comment Utility
OK.  Thanx Sven.  I guessed it would come down to the dreaded build from the tarball :-(

I tried with the --enable-nvidia=no option in the configure, but I get problems because the compiler can't find SDL.h

I've tried freshmeat.net, but there are a lot of SDL (or SDL related) items.  I'm pretty sure I can ignore the Perl and LISP wrappers, but can you provide any info about where to get the SDL files that I need (preferably ones that I don't need to build :-)).

I always seem to find that it's one step forward and three back :-(
0
 
LVL 15

Author Comment

by:jimmack
Comment Utility
Just tried Glenn's comment, but for both the SDL and non-SDL src.rpm's, I got "Bad exit status" followed by "RPM build errors".

The amount of implicitly declared functions and unused variables makes it quite difficult to see where the real problems are.
0
 
LVL 20

Accepted Solution

by:
Gns earned 200 total points
Comment Utility
I just said it *might* work:-):-).

Care to share a snippet of the errors? Probable that the first one is more "significant...

Perhaps best to go with a more "traditional" tarball build then. At least will make it possible to deconfigure.

Hm. Did you install the libSDL1.2-devel-1.2.5-5mdk.i586 package (found on CD3 of the install CDs ... <CD mount point>/Mandrake/RPMS3/libSDL1.2-devel-1.2.5-5mdk.i586.rpm)?

-- Glenn
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 20

Expert Comment

by:Gns
Comment Utility
Oops... accidental submit... disregard the "At least will make it possible to deconfigure." bit:-).

-- Glenn (a.k.a. Le Grand Typo)
0
 
LVL 15

Author Comment

by:jimmack
Comment Utility
Thank you Glenn.  That's it.

It's a crying shame that Linux is such a pain in the arse to deal with.

No.  On second thoughts, that's not quite what I mean.  It's not a problem with Linux, the problem is with the help/feedback/support of the development tools (specifically RPM).  Just being told that a particular header file of .so.1 is missing or incompatible is still too primitive.

Anyhoo.  Thanks again.  I installed the libSDL1.2-devel.... RPM using rpmdrake (happily, it picked out the other dependencies).  Once this was done, I un-tarred the source tarball, built it with the --enable-nvidia=no and lo and behold, it worked.

Sadly, I've only learned that I should have checked the DVD for the library before whinging :-(  I was hoping (in a kind of sick and masochistic way) that the problem would be a bit more complex and that you Linux gurus would be able to point me in the direction of some really good tool/site that would solve all my problems ;-)

Still. I've got what I need this time.  I'll be back again... count on it ;-)

Thanx.

Jim.
0
 
LVL 9

Expert Comment

by:svenkarlsen
Comment Utility
Jim,

you could give it ago with the RPM from Feodora:

http://rpm.pbone.net/index.php3/stat/4/idpl/826654/com/foobillard-2.8-0.fdr.3.rh90.i386.rpm.html

It's a redhat version that may be a little differently compiled

Sven
0
 
LVL 20

Expert Comment

by:Gns
Comment Utility
Ah, the joys of dependencies... This is one of the things I've always eben a bit miffed with too:-).

Next time you try incorporating a "foreign" rpm, do a
rpm -qiRp <package file>
to list those "pesky" deps.
Then ... well "locate" and "rpm -qilp" is your friend (along with some constructive scripting:-).

One could view rpmdrake as such a tool... After all, it takes the "known" packages from the hdlist files.... etc etc.

The Debian deb system have some small inconveniences too, not to mention slacks tarball strategy....

I'll take them any day though, as long as they are part of a free alternative (most unices also have some halfbaked package-handling system or other... or (shudder) something more akin to the non-system M$ employs).

Have fun/be seeing you!

-- Glenn
0
 
LVL 15

Author Comment

by:jimmack
Comment Utility
;-)
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now