Solved

eth0 and network problem (network card not recognized)

Posted on 2003-12-01
8
969 Views
Last Modified: 2008-03-03
My Magellan Pro robot(ret hat 6.2) was experiencing a problem as follows. Last night after modifying a c++ program on the Linux for many times and finally got an error of file jam. Then the Linux cannot reboot any more. Fortunately, after several hours' effort, the Linux can reboot. However, there occur a problem of eth0:

(1): use lspci and lsmod, found Ethernet card is not recognized and driver module is not loaded! (no result shown as follows:
Ethernet controller: Realtek Semiconductor Co., Ltd.
rtl8139 11748 0 (autoclean) )

(2): use modprobe rt18139.o
Can't locate module rt18139.o

(3):insmod rt18139
init_module: Device or resource busy

(4)cat /proc/interrupts

the result does not contain an IRQ for the network card

(5)cat /proc/net/dev
only shows information about lo but no information about eth0


The plug of network cable and the network card seem to be well enough.  Please advice us accordingly.

Looking forward to your reply as soon as possible. Thanks a lot!

Best regards,
Lai

/************************All the messages during the boot and the response of my command is recorded as the following***************************/

[root@irobot /]# Sending all procmd: recovery thread got woken up ...

esses the KILL smd: recovery thread finished ...

ignal.. mdrecoveryd(6) flushing signals.

Turning off swap
Turning off quotas
Unmounting file systems
Remounting remaining filesystems (if any) readonly
Please stand by while rebooting the system...
stopping all md devices.

Restarting system.

LILO boot:
Loading linux............
Linux version 2.2.14-5.0 (root@porky.devel.redhat.com) (gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 Tue Mar 7 21:07:39 EST 2000

Detected 1002291471 Hz processor.

Console: colour VGA+ 80x25

Calibrating delay loop... 999.42 BogoMIPS

Memory: 127916k/131072k available (1060k kernel code, 412k reserved, 1620k data, 64k init, 0k bigmem)

Dentry hash table entries: 262144 (order 9, 2048k)

Buffer cache hash table entries: 131072 (order 7, 512k)

Page cache hash table entries: 32768 (order 5, 128k)

VFS: Diskquotas version dquot_6.4.0 initialized

CPU: Intel Pentium III (Coppermine) stepping 06

Enabling extended fast FPU save and restore...done.

Not enabling KNI unmasked exception support

Exception 19 error handler not integrated yet

Disabling CPUID Serial number...done.

Checking 386/387 coupling... OK, FPU using exception 16 error reporting.

Checking 'hlt' instruction... OK.

POSIX conformance testing by UNIFIX

mtrr: v1.35a (19990819) Richard Gooch (rgooch@atnf.csiro.au)

PCI: PCI BIOS revision 2.10 entry at 0xfb1e0

PCI: Using configuration type 1

PCI: Probing PCI hardware

Linux NET4.0 for Linux 2.2

Based upon Swansea University Computer Society NET3.039

NET4: Unix domain sockets 1.0 for Linux NET4.0.

NET4: Linux TCP/IP 1.0 for NET4.0

IP Protocols: ICMP, UDP, TCP, IGMP

TCP: Hash tables configured (ehash 131072 bhash 65536)

Initializing RT netlink socket

Starting kswapd v 1.5

Detected PS/2 Mouse Port.

Serial driver version 4.27 with MANY_PORTS MULTIPORT SHARE_IRQ enabled

ttyS00 at 0x03f8 (irq = 4) is a 16550A

ttyS01 at 0x02f8 (irq = 3) is a 16550A

ttyS02 at 0x03e8 (irq = 0) is a 16550A

ttyS03 at 0x02e8 (irq = 3) is a 16550A

pty: 256 Unix98 ptys configured

apm: BIOS version 1.2 Flags 0x07 (Driver version 1.9)

Real Time Clock Driver v1.09

RAM disk driver initialized:  16 RAM disks of 4096K size

PIIX4: IDE controller on PCI bus 00 dev 39

PIIX4: not 100% native mode: will probe irqs later

    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:pio, hdb:pio

hda: IC25N030ATCS04-0, ATA DISK drive

ide2: ports already in use, skipping probe

ide0 at 0x1f0-0x1f7,0x3f6 on irq 14

hda: IC25N030ATCS04-0, 28615MB w/1768kB Cache, CHS=3648/255/63

Floppy drive(s): fd0 is 1.44M

FDC 0 is a post-1991 82077

md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12

raid5: measuring checksumming speed

raid5: KNI detected, trying cache-avoiding KNI checksum routine

   pIII_kni  :  1901.952 MB/sec

raid5: MMX detected, trying high-speed MMX checksum routines

   pII_mmx   :  2330.958 MB/sec

   p5_mmx    :  2474.595 MB/sec

   8regs     :  1724.406 MB/sec

   32regs    :   981.075 MB/sec

using fastest function: pIII_kni (1901.952 MB/sec)

scsi : 0 hosts.

scsi : detected total.

md.c: sizeof(mdp_super_t) = 4096

Partition check:

 hda: hda1 hda2 < hda5 hda6 hda7 hda8 hda9 >

autodetecting RAID arrays

autorun ...

.. autorun DONE.

VFS: Mounted root (ext2 filesystem) readonly.

Freeing unused kernel memory: 64k freed

INIT: version 2.78 booting
                  Welcome to Red Hat Linux
            Press 'I' to enter interactive startup.
Mounting proc filesystem [  OK  ]
Configuring kernel parameters [  OK  ]
Setting clock  (utc): Mon Dec  1 00:44:53 GMT 2003 [  OK  ]
Activating swap partitions [  OK  ]
Setting hostname irobot.com [  OK  ]
Checking root filesystem
/dev/hda6: clean, 6914/34136 files, 46077/136521 blocks
[/sbin/fsck.ext2 -- /] fsck.ext2 -a /dev/hda6
[  OK  ]
Remounting root filesystem in read-write mode [  OK  ]
Finding module dependencies depmod: not an ELF file
[  OK  ]
Loading sound module (es1371) [  OK  ]
Checking filesystems
/dev/hda9: clean, 3950/3407872 files, 648342/6803519 blocks
/dev/hda7: clean, 17/34136 files, 4333/136521 blocks
/dev/hda1: clean, 23582/193152 files, 123717/385552 blocks
/dev/hda5: clean, 141/34136 files, 18650/136521 blocks
Checking all file systems.
[/sbin/fsck.ext2 -- /home] fsck.ext2 -a /dev/hda9
[/sbin/fsck.ext2 -- /tmp] fsck.ext2 -a /dev/hda7
[/sbin/fsck.ext2 -- /usr] fsck.ext2 -a /dev/hda1
[/sbin/fsck.ext2 -- /var] fsck.ext2 -a /dev/hda5
[  OK  ]
Mounting local filesystems [  OK  ]
Turning on user and group quotas for local filesystems [  OK  ]
Enabling swap space [  OK  ]

INIT: Entering runlevel: 3
Entering non-interactive startup
Setting network parameters [  OK  ]
Bringing up interface lo [  OK  ]
Bringing up interface eth0 insmod: /lib/modules/2.2.14-5.0/net/rtl8139.o: insmod eth0 failed
Delaying eth0 initialization.
[FAILED]
Starting portmapper: [  OK  ]
Starting NFS file locking services:
Starting NFS lockd: [  OK  ]
Starting NFS statd: [  OK  ]
Starting up APM daemon: [  OK  ]
apmd[309]: Charge: * * * (-1% unknown)
Initializing random number generator [  OK  ]
Mounting other filesystems [  OK  ]
Starting system logger: [  OK  ]
Starting kernel logger: [  OK  ]
Starting identd: [  OK  ]
Starting at daemon: [  OK  ]
Starting cron daemon: [  OK  ]
Starting INET services: [  OK  ]
Starting keytable [  OK  ]
Starting httpd: Syntax error on line 403 of /etc/httpd/conf/httpd.conf:
Invalid command 'PerlHandler', perhaps mis-spelled or defined by a module not included in the server configuration
[FAILED]
Starting linuxconf [  OK  ]


Red Hat Linux release 6.2 (Zoot)
Kernel 2.2.14-5.0 on an i686

irobot login:
root
Password:
Last login: Sun Nov 30 23:53:02 on tty1
78COLUMNS=80;
LINES=24;
export COLUMNS LINES;
[root@irobot /root]# lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge (AGP disabled) (rev 03)
00:07.0 ISA bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
00:0f.0 Multiport serial controller: Quatech Inc: Unknown device 0030 (rev 43)
00:12.0 VGA compatible controller: Chips and Technologies F69000 HiQVideo (rev 64)
00:13.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
[root@irobot /root]# lsmod
Module                  Size  Used by
lockd                  30344   1  (autoclean)
sunrpc                 52132   1  (autoclean) [lockd]
es1371                 25092   0  (unused)
soundcore               2628   4  [es1371]
[root@irobot /root]# mode probe rt18139.o
modprobe: Can't locate module rt18139.o
[root@irobot /root]# /cat    cat /rp   /proc/interrupts
           CPU0      
  0:      42517          XT-PIC  timer
  1:          2          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  4:        423          XT-PIC  serial
  8:          1          XT-PIC  rtc
 12:          0          XT-PIC  es1371
 13:          1          XT-PIC  fpu
 14:      43637          XT-PIC  ide0
NMI:          0
[root@irobot /root]# cat /proc/interrupts               net/dev
cat: /net/dev: No such file or directory
[root@irobot /root]# cat /proc/net/dev
Inter-|   Receive                                                |  Transmit
 face |bytes    packets errs drop fifo frame compressed multicast|bytes    packets errs drop fifo colls carrier compressed
    lo:    1260      18    0    0    0     0          0         0     1260      18    0    0    0     0       0          0
[root@irobot /root]# cd /etc
[root@irobot /etc]# cd sysconfig/
[root@irobot sysconfig]# ls
apm-scripts/  desktop  keyboard             pcmcia.rpmsave
apmd            hwconf   mouse             sendmail
clock            i18n     network             soundcard
console/      init     network-scripts/  static-routes
[root@irobot sysconfig]# cd ..
[root@irobot /etc]#  cd ..
[root@irobot /]# cd /lib/modules/2.2.14-5.0/net/rtl8139.o cd /lib/modules/2.2.14-5.0/net/rtl8139.o 
[root@irobot /]# c /lib/modules/2.2.14-5.0/net/rtl8139.o 
[root@irobot /]# i /lib/modules/2.2.14-5.0/net/rtl8139.o
[root@irobot /]# in /lib/modules/2.2.14-5.0/net/rtl8139.o
[root@irobot /]# ins /lib/modules/2.2.14-5.0/net/rtl8139.o
[root@irobot /]# insm /lib/modules/2.2.14-5.0/net/rtl8139.o
[root@irobot /]# insmo /lib/modules/2.2.14-5.0/net/rtl8139.o
[root@irobot /]# insmod /lib/modules/2.2.14-5.0/net/rtl8139.o
[root@irobot /]# insmod
/lib/modules/2.2.14-5.0/net/rtl8139.o: init_module: Device or resource busy
[root@irobot /]#

0
Comment
Question by:laixch
8 Comments
 
LVL 2

Expert Comment

by:TheWeakestLink
ID: 9851187
It looks like the "file jam" has corrupted part of your OS (I never heard the term "file jam" before - where did it come from?).   You may have to re-install.  If you have any data you need to preserve, archive it somehow.

When you spent some time to get back to where you could reboot, did the first fsck runs show errors?  It may be that they found file system errors which didn't get fixed, but got moved to the lost+found areas.

It may be that you could copy the relevant modules to the /usr/lib/modules/<kernel revision> area from the install CDs, but any time I tried that in the past, I spent ages trying and finally re-installed anyway.

Maybe someone else can come up with a magical fix, but I'm pessimisitic.

Paul
0
 
LVL 5

Expert Comment

by:brabard
ID: 9856719
I think in the end reinstalation of Linux will be the solution , but starting from the begining the main problem is that OS coudn't see you pci NIC - the output of lspci .
One of possible reasons is misunderstanding between the OS and the BIOS pci routing table .
But I see "PCI: PCI BIOS revision 2.10 entry at 0xfb1e0" during startup , wich is rignt message , so I am confused .
Do you use something like PCI=BIOSIRQ in lilo ?
0
 

Author Comment

by:laixch
ID: 9859301
thanks for your reply. Some more information:

(1) No particular item for network card exists in bios settings, but I have tried enable/disable PnP in bios settings. No effect.

(2): Use modprobe rt18139 rather than use modprobe rt18139.o also gets a response
Can't locate module rt18139

(3): ifconfig eth0
eth0: error fetching interface information: Device not found

(4): If another PCI card is inserted into the robot's PCI slot, it will be listed with 'lspci' command.

Since the Ethernet controller is built into the motherboard of the computer, I think the problem mainly lies in that the device can not be recognized by the computer.
This made me a bit pessimisitic.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 2

Expert Comment

by:TheWeakestLink
ID: 9859773
Sounds like the devices setup in /dev may have been partially corrupted.

Have you tried going for an install of the same version of Linux, as if there wasn't an OS already there, but without comitting any changes?  You should be able to see if the card is detected under those circumstances.  If it shows up, my guess is that you'll have to reinstall.  

Not what you wanted to hear.......

Paul
0
 
LVL 5

Expert Comment

by:brabard
ID: 9864931
No matter it is builded in or external board , the device is connected to the PCI bus , so have to be listed in /proc/pci .
But the WeakestLink is right - could you try to install Knoppix from CD and see if it will find your hardware proper .
0
 
LVL 4

Accepted Solution

by:
kiffney earned 125 total points
ID: 9883239
Instead of modprobe,  try

insmod rtl8139

note that the file name is RTL8139 in lower case, not RT18139 as you were typing (might have been a typo).
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now