Converting docs from WordPerfect to Word

I am attempting to convert legal documents from WordPerfect 6.1 to Word XP.  I have tried almost every 3rd party converter out there, as well as the built-in converters in Word.  I always have had the exact same result.  Here's the problem:

Legal pleadings created in WordPerfect are created by using a Watermark.  (FYI, legal pleadings are paper with a line of vertical numbers, usually 1-28, double-spaced, that run vertically down the left side.  There is also a double vertical line just to the right of the numbers, and a single vertical line on the right side of the document.)  When these docs are converted to Word, Word interprets the watermark differently, and I have to go into Headers and Footers to strip it out.  (I haven't found a way to salvage it at all.)  Word then has a legal pleading wizard in which I have created a template to look identical to the one in WordPerfect.  When I open a new document based on the template, then select Insert/File to insert my file to the document, the template is only applied to the last page.  

HELP!!!  Please!  Any and all advice is greatly appreciated!  Thank you!
drache21Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joanne M. OrzechManager, Document Services CenterCommented:
Have you tried using WordPort to convert your docs?  Not sure if it would work but...

0
drache21Author Commented:
Yes - I tried WordPort.  I didn't see a difference at all.  :(  
0
Joanne M. OrzechManager, Document Services CenterCommented:
If you could send me one of the files, that would be helpful.  Email in profile.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Anne TroyEast Coast ManagerCommented:
JOrzech is a great source for help with this issue.
But I can't tell you why.
'Cause then I'd have to kill you.
0
Joanne M. OrzechManager, Document Services CenterCommented:
ROFL :))

Is that a veiled threat DB?   he  he
0
drache21Author Commented:
I just sent it to your e-mail address.  I can't thank you enough.  I'm about ready to tear my hair out, and I can't spare any!
0
Joanne M. OrzechManager, Document Services CenterCommented:
OK - here's the scoop.  I can get it to work but it takes a little bit of effort and I don't know how many of these you need to convert.  Here's what I had to do to make it work:

Open *.wpd in Word.  View, Header, Control A, delete.  You must do this for every header in the document.
Save and close document as a Word doc (let's say "new pleading.doc").
Open pleading.doc (I am sending one I created to you).
Insert, File, "new pleading.doc".
Go to last page header - control a, copy.
Paste into every header in the document.

The reason you're having this problem, is because there are continuous section breaks in your document due to the way your captions were created in WordPerfect.  I would STRONGLY suggest you use Word tables instead for the future.  In any event, the header (watermark) can be different for each section in Word.  That's why you have to paste it into every header.

I'm sure there's a way to automate this...but as I said, I don't know how many you have to convert.    It would require a bit of time and some VB coding....Please let me know if I can be of further assistance.

0
Anne TroyEast Coast ManagerCommented:
Jo...cant' she delete all those continuous section breaks?
I used to be able to do it....
Just use the find/replace...
Find section break, replace with <nothing>
Replace all
0
Joanne M. OrzechManager, Document Services CenterCommented:
You can but it screws up the caption box royally!  It's in columns....
0
drache21Author Commented:
When I follow your instructions, and do a file/insert, the template is still only applied to the last page.  Any ideas?
0
Anne TroyEast Coast ManagerCommented:
By *template*, I assume you mean header/footer?

The section breaks are causing that.....
Delete the section breaks and THEN copy over...
0
drache21Author Commented:
I mean the line numbering.  Even after I deleted all of the section breaks, the line numbering only shows up on the last page.
0
Joanne M. OrzechManager, Document Services CenterCommented:
As I said above:

Go to last page header - control a, copy.
Paste into every header in the document.

Then it will work properly.


Dreamboat...the section breaks are in the document she's inserting into the template (which should really be a document).  If she deletes the section breaks, it messes up her caption box....because the caption box is in columns.  I will send to you.


0
drache21Author Commented:
It worked!  Yeah!  Do you know what about the header causes this?  

Of course, since I deleted the section breaks, the formatting doesn't even seem salvagable.  :(  

One more quick thing - is there a way to change the font on the numbers for the pleading paper?  I haven't been able to get the lines to match up with the numbers.  :(

Thank you so much!  You're a lifesaver!
0
Joanne M. OrzechManager, Document Services CenterCommented:
I would try the whole exercise over - except don't delete the section breaks....then you'll get the result you want.

You may have problems because you also had column breaks in there...maybe Dreamboat can elaborate on that point.

Also, the line numbers are simply characters in a text box.  You'll need to View, Header, and then click on the text box and change the font to what you want.  Also, I set the paragraph formatting (Format, Paragraph, Line Spacing, to exactly 22.75 pts)....you may just want to try increasing/decreasing that until you get the desired result.

Glad to have helped.  Let us know if there's anything else...

Joanne
0
Anne TroyEast Coast ManagerCommented:
Yuk, drache21. That left/right format just sucks. You know which one I mean.
I don't see any easy way to automate that.

Font? No---probably paragraph spacing.
Try Ctrl+A to select everything in the doc (not in the header).
Hit Format-Paragraph and check line spacing.
WordPerfect docs generally come through with some weirdo setting there.

You may also want to go to Tools-Options, change the compatibility to WP or something. Play around there. It may make some of these edits unnecessary? Shot in dark!
0
Anne TroyEast Coast ManagerCommented:
LOL, Jo!
0
Joanne M. OrzechManager, Document Services CenterCommented:
So... you find me amusing do you DB?  It's a harsh lesson....but practice makes perfect :)) LOL

0
Anne TroyEast Coast ManagerCommented:
I meant...we both posted a bunch o' the same info...

Drache21: Sometimes I just jump in to help out a bit and people end up splitting points when I've done virtually nothing. JO so obviously did all the work here...please award all points to her!

But I bet you could drag this one out for awhile until all your problems are solved and automated... :)
0
Joanne M. OrzechManager, Document Services CenterCommented:
oh - ic

As always, thanks for your input DB.  It's always good to have another set of eyes (and brain:)
0
drache21Author Commented:
You both have been extremely helpful, and extremely entertaining!

I tried it over without deleting the section breaks, and then I had the same problem as before - the numbering is only on the last page.

The font changes worked perfectly though.

I promise I won't drag this out too much longer!  :)
0
Joanne M. OrzechManager, Document Services CenterCommented:
As I said above:

Go to last page header - control a, copy.
Paste into every header in the document.

Then it will work properly.


0
drache21Author Commented:
I did exactly that.  Without deleting the section breaks, it wouldn't work.  

What is the deal with the headers?  Do you know what causes that?  Thank you!
0
Joanne M. OrzechManager, Document Services CenterCommented:
I can't understand why it wouldn't but....stranger things have happened.

This is what you're doing?
1.  Go to the last page, View, Header, Control A, Copy.
2.  Go to the beginning of the document, View, Header, Paste.  View next header, paste.

That's NOT working now???



0
Anne TroyEast Coast ManagerCommented:
Sorry, drache21.

I meant to post this earlier...

http://www.theofficeexperts.com/NewsLetters/July2002.doc

Read the bit about Header to Footer Break Dancing

That explains headers and footers, probably in a little more detail than you NEED, but you'll be better with Word when you're done reading it. I wrote it, so if you have any questions after that, let me know.

The gist is this:
Header and footer contents are *stored* with section breaks.
The section breaks you're bringing in from the other doc do NOT have your header/footer contents *stored* in them, see? So you end up with only the header and footer in the final section.
0
Joanne M. OrzechManager, Document Services CenterCommented:
Thanks DB... I just emailed her the one I did which DOES contain the section breaks...so hopefully we can figure this out
0
drache21Author Commented:
I did the copies and pastes after I deleted the original headers.  (i.e. the whacky page numbering.)  Could that be causing it?  
0
Anne TroyEast Coast ManagerCommented:
JO:

I recorded this:

Sub Macro1()
'
' Macro1 Macro
' Macro recorded 12/2/2003 by Anne Troy
'
    Selection.EndKey Unit:=wdStory
    If ActiveWindow.View.SplitSpecial <> wdPaneNone Then
        ActiveWindow.Panes(2).Close
    End If
    If ActiveWindow.ActivePane.View.Type = wdNormalView Or ActiveWindow. _
        ActivePane.View.Type = wdOutlineView Then
        ActiveWindow.ActivePane.View.Type = wdPrintView
    End If
    ActiveWindow.ActivePane.View.SeekView = wdSeekCurrentPageHeader
    Selection.WholeStory
    Selection.Copy
    ActiveWindow.ActivePane.View.SeekView = wdSeekMainDocument
    Selection.HomeKey Unit:=wdStory
    If ActiveWindow.View.SplitSpecial <> wdPaneNone Then
        ActiveWindow.Panes(2).Close
    End If
    If ActiveWindow.ActivePane.View.Type = wdNormalView Or ActiveWindow. _
        ActivePane.View.Type = wdOutlineView Then
        ActiveWindow.ActivePane.View.Type = wdPrintView
    End If
    ActiveWindow.ActivePane.View.SeekView = wdSeekCurrentPageHeader
    Selection.WholeStory
    Selection.Paste
    Selection.Delete Unit:=wdCharacter, Count:=1
    ActiveWindow.ActivePane.View.NextHeaderFooter
    Selection.HeaderFooter.LinkToPrevious = Selection.HeaderFooter. _
        LinkToPrevious
    ActiveWindow.ActivePane.View.SeekView = wdSeekMainDocument
End Sub


Can you tell? Hee hee.
It goes to the LAST section header, copies it, and puts it into the first section's header.
It then goes to the next section and changes it to "Same as Previous"
Can you possibly edit it to:
--Make ALL section headers same as previous
--go to First section header and paste from clipboard (instead of pasting first, then changing same as previous)
--do the same for footers
0
drache21Author Commented:
The one you sent me looks great!  What am I doing wrong?  :(

I go to View/Header and Footer.  I then go to the last page, click ctrl+A, then ctrl+c, then on every header I click ctrl+v.  I also tried the actual copy and past buttons.  The numbering won't appear on the first pages.

Did you delete ANY section breaks?  Column breaks?  Am I just slow?
0
Joanne M. OrzechManager, Document Services CenterCommented:
No - I didn't delete anything....

After I deleted the headers from the document and saved it - I just inserted it into the template itself and did the copy and paste into the headers....

I'll have to look at this maybe again tomorrow....I'm under the gun to write a macro for someone here...

I'm gonna sleep on it... sorry drache.  


0
Anne TroyEast Coast ManagerCommented:
>>Am I just slow?

Understanding headers and footers and page numbering in Word was one of the hardest things I ever had to get through this thick skull of mine.

The steps you took are wrong, I think.

1. Open document
2. Hit Ctrl+End to get to last page
3. Hit View-Header and footer
4. Hit Ctrl+A
5. CLOSE header and footer
6. Ctrl+Home
7. View Header and footer
8. Ctrl+A
9. Ctrl+V
10. Hit delete key once.
11. Hit Show Next button.
12. Repeat from step 9 until all headers have your headers.
0
drache21Author Commented:
I followed these steps to the letter with no luck.  :(  
0
Joanne M. OrzechManager, Document Services CenterCommented:
Ok drache...

After a good nights sleep -- did you try again?  Still not working?
0
drache21Author Commented:
It still isn't working.  I opened the document, deleted all of the headers, then saved the document.  I then copied the last header and pasted it into all of the other headers.  I then closed the document, opened the template, selected insert/file, and I'm still not seeing numbers on any pages except the last.  Am I doing something in the wrong order?  
0
Joanne M. OrzechManager, Document Services CenterCommented:
Yes I think you are doing it out of order....that may be the problem.  Here's what you said:


I opened the document, deleted all of the headers, then saved the document. - YES
I then copied the last header and pasted it into all of the other headers.   NO
I then closed the document, NO
opened the template, selected insert/file, YES
and I'm still not seeing numbers on any pages except the last.  Am I doing something in the wrong order?   YES

1.  Open the document.
2.  Delete all headers.
3.  Close and save document.
4.  Open template
5.  Insert/File into template.
6.  Go to last page of TEMPLATE header
7.  Control A, copy
8.  Paste into all other headers.

Let me know.
Joanne


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
drache21Author Commented:
It worked!  Thank you SO MUCH!  I wish I had more points in my account to give you!  Thanks again!
0
Joanne M. OrzechManager, Document Services CenterCommented:
Thanks drache...glad it worked.... :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Word

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.