Dealing with empty crystal reports through crystal report app. server [RAS]

Hello,

I have successfully deployed access to our reports through web using RAS and CR[9.0]. We use ASP and CrystalReportPartsDefinition.

When I display part of the report, I get an error when report is empty as request part [usually a graph] is not created in empty report.

Could someone help?

Thanks.
JaiJavan20194Asked:
Who is Participating?
 
mnyeConnect With a Mentor Commented:
according to crystal this is a known issue with no current fix.

http://support.crystaldecisions.com/library/kbase/articles/c2011603.asp

sorry
matt
0
 
mnyeCommented:
not sure exsactly what you mean, but some null errors handling or suppression formulas in the section that is returning no records.  give more specifics and i can suggest something.

Is it an ASP error?  what is the source of the error?
matt
0
 
frodomanCommented:
If the graph is in your header or footer, you can use the section expert in CR9 and select the "Suppress Blank Section" option.

Otherwise as Matt said please provide more details.
0
 
JaiJavan20194Author Commented:
Hello,
    Sorry...I should have been more specific.
    I get following error which is from webreporting.dll
====================
Error Type:
webReporting.dll (0x800002E8)
Error in File C:\WINDOWS\Temp\{0D12D160-EF26-4626-890F-3F0C770E90E3}.rpt: Get/Drill report part(s) failed - the data context '' is not valid.
/BPA/inc/utilmain.asp, line 1406
====================
   This happens only when report is empty i.e. no data for the user and hence no graph is created. Hence, when I request for only the graph through PartsViewer, I get above error as the report is empty and hence presumably the graph [object] is not created.
   I am attaching section of the code where I access report parts.
=====================
Set objFactory = CreateObject("CrystalReports.ObjectFactory.2")
Set def = ObjFactory.CreateObject("CrystalReports.CrystalReportPartsDefinition")
Set nodes = def.ReportPartNodes

Set node0 = ObjFactory.CreateObject("CrystalReports.CrystalReportPartNode")
node0.Name = txtNodeName
nodes.Add (node0)

Set HTMLViewer = objFactory.CreateObject("CrystalReports.CrystalReportPartsViewer")
With HTMLViewer
      .IsOwnPage = False
End With

Set oClientDoc=objFactory.CreateObject("CrystalClientDoc.ReportClientDocument")
oClientDoc.Open txtReportName
oClientDoc.DatabaseController.Logon "readonly","readonly"
HTMLViewer.ReportSource = oClientDoc.ReportSource

---- Code to set parameters -----
---- Following line I get the error ----
Response.write(HTMLViewer.ProcessHTTPRequest(Request, Response))
=============================

Thanks.


 
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.