Solved

Geforce Ti4600 gets 'stuck in a loop'

Posted on 2003-12-01
20
1,803 Views
Last Modified: 2013-11-08
I've just installed a new MSI Neo 875p Mobo, 512Mb DDR ram (across two 256Mb channels) and a P4 3GHz chip.
But now my existing graphics card, a Geforce 4 TI4600 is giving me a problem.
After a period of time - up to 50 minutes from a cold start (ie the machine having been left off for 20 minutes or so) the system shuts down and restarts - but never gets beyond the 'loading Windows XP' screen before it shuts down and restarts again. I have to switch off the system, leave it for a minimum of 20 minutes, then start again.

I've had several error logs generated all of which say the same thing: ' The driver for the display device got stuck in an infinite loop. This usually indicates a problem with the device itself or with the device driver programming the hardware incorrectly. Please check with your  display device vendor for any driver updates.'

I had the latest drivers installed (6.14.10.4404) but after this problem occurred a couple of times, I uninstalled the card and went right back to the native Windows XP driver. Unfortunately, a key file - nv4_disp.dll - wasn't detected during reinstallation, so I had to resort to the one existing in my system, which might not have helped.

The new Mobo has an AGP 8X slot, and my card is 4x - could this be part of the problem?
I wasn't sure if it would help, but I tried reducing the size of the AGP memory aperture in BIOS from 64Mb to 32, but I still had the problem. Should I try increasing it to the maximum memory of my card (128Mb?)

What else can anyone suggest I could try to get stability back?
0
Comment
Question by:EricCartman
  • 9
  • 7
  • 2
  • +2
20 Comments
 
LVL 32

Expert Comment

by:Luc Franken
ID: 9853643
I suspect something is overheating.
0
 
LVL 32

Expert Comment

by:Luc Franken
ID: 9853666
But to be sure:

try "Start" => "Settings" => "Control Pannel" => "System" => "Advanced" => "Startup and Recovery" => uncheck the box just before "automatically reboot"

Next time this happens, I think you'll get a blue screen. Look up the error code at http://www.aumha.org/win5/kbestop.htm and see if you can find a solution there.
0
 
LVL 14

Expert Comment

by:tmj883
ID: 9854179
Aperature should be at 128 for this video card. T
0
 
LVL 9

Accepted Solution

by:
buckeyes33 earned 125 total points
ID: 9854317
>The new Mobo has an AGP 8X slot, and my card is 4x - could this be part of the problem?
No as long as you have it set at 4X in the bios.  

>I had the latest drivers installed (6.14.10.4404) but after this problem occurred a couple of times,
This is not the correct driver for your video card.  This is the newest driver

http://www.nvidia.com/object/winxp_2k_52.16
Personally I would not use this one.  It has had some major problems with certian games (does not work right).  I would use one of this one untill they update the drivers again and fix the problems, which I hope is soon.

http://www.nvidia.com/object/pc_winxp-2k_45.33.html
0
 
LVL 9

Expert Comment

by:buckeyes33
ID: 9854324
> I would use one of this one untill they update the drivers again and fix the problems
should read:  I would use one of the old ones untill they update the drivers again and fix the problems.
0
 

Author Comment

by:EricCartman
ID: 9865029
Before I respond I forgot to mention that one of the symptoms I've had is graphical artefacts - columns of colour - that appear when I was forced to reboot.

So, I did what LucK suggested and the error message reported that the fault is apparently 'Driver IRQL not less or equal'. Something to do with drivers, by the look of it.
I followed the link buckeyes33 gave and downloaded the Nvidia drivers. Installed them, and rebooted - still had the artefacts, though. I had problems, too - I ended up having to do a lot of work in 'safe' mode.
After finally getting a normal boot, the system worked for about 20 minutes then hung again - same error message.

I have noticed that the IRQ of the card is 16, whereas earlier I'm sure it was about 11, which is odd.
I've checked the heat, by the way - after about 50 minutes the CPU is at 51C and the system is at 31C. Pretty good compared to my old Athlon system. I took the case off and checked the Geforce was, which was warm, but didn't feel as hot as I'd expect if there was a heat problem.

So things still aren't good - anyone got any further suggestions as to how I can get everything back to normal?
0
 
LVL 32

Assisted Solution

by:Luc Franken
Luc Franken earned 125 total points
ID: 9866015
Take a look here:

Error Message with RAM Problems or Damaged Virtual Memory Manager
http://support.microsoft.com/?kbid=810093
0
 
LVL 32

Expert Comment

by:Luc Franken
ID: 9866019
0
 

Author Comment

by:EricCartman
ID: 9867380
I found those articles, LucF, thanks.
I've got two brand new 256Mb  DDR 3200 RAM modules installed, so first of all I'll try removing one and then the other and see if that has any effect.
If not, I'll have a go with the virtual memory manager changes recommended.
I'm puzzled as to how this could lead to graphical artefacts and the finger being pointed at the Ti4600, but I'll try anything.
I'll let you know what happens...
0
 

Author Comment

by:EricCartman
ID: 9874483
Before I tried fiddling with RAM I did one more thing - I had noticed a reference to a file called ftpfilt.dll in the 'IRQL' error message, and on discovering that it was someting to do with Outpost firewall, I disabled the firewall and went online.
Within a few minutes I had a forced restart due to the 'remote procedure call' shutting down unexpectedly.
When the machine rebooted it was stable for a few minutes before it shut down again giving me a different blue screen error - in fact, the 'stuck in a loop' error that led me to start this thread!
This one's number ends in 'EA', which according to the knowledge base is 'thread stuck in device driver' and this was clearly related to my graphics card.
So I followed the 'workaround' advice, and set the card's accelleration to zero and turned off write combining.
Since there could have been a heat issue, I also reinstalled a fan in the front of the PC case.
Today the machine has been stable for five hours.
But when I tried increasing the accelleration and re-enabling write combining and restarting it didn't get any further than the Windows loading screen.
I'm not sure what to do now - clearly things work OK without accelleration, but I need accelleration to run games. So is the card faulty or could it be that I need different drivers to the ones I installed at the suggestion of buckeyes?
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 32

Expert Comment

by:Luc Franken
ID: 9874592
>> Within a few minutes I had a forced restart due to the 'remote procedure call' shutting down unexpectedly.
Blaster Virus Alert!!

First I have to tell you this: try keeping your system up-to-date using http://windowsupdate.microsoft.com

Security patch for windows: http://microsoft.com/downloads/details.aspx?FamilyId=2354406C-C5B6-44AC-9532-3DE40F69C074&displaylang=en
Removal tool: http://securityresponse.symantec.com/avcenter/FixBlast.exe

First solve this, then we can look at the rest.
0
 

Author Comment

by:EricCartman
ID: 9875489
What a mess I'm in!
The fact that I had to reinstall XP after rebuilding my system (it totally refused to start), meant that I lost Service Pack 1, so I'll try and reinstall it to get things back to normal. I'll also check that XP auto-update is running.
I'd have thought my regularly updated Norton Anti-virus (which I run weekly) would have sorted the virus problem out, but since I've not run a complete sweep since rebuilding my system last weekend, maybe the virus has sneaked in since then.
I'll do what you suggest, LucF and report back (assuming I can keep my machine stable for long enough...)
0
 
LVL 32

Expert Comment

by:Luc Franken
ID: 9875540
>I'll do what you suggest, LucF and report back (assuming I can keep my machine stable for long enough...)
Start => Settings => Control Pannel => Administrative tools => Services => scroll towards "Remote Procedure Call" => rightclick it and choose "Properties" => Recovery => set all failures to "take no action"
Now you should have enough time to install the patch. After you've done this, boot to safe mode, and run the removal tool.
0
 

Author Comment

by:EricCartman
ID: 9881007
Things have got worse.
I ran the removal tool, so the Blaster virus is no more (it had infected only one file) but then I thought I'd try to d/l the Windows XP SP 1 to give my system all the security updates etc.
Half way through the process, the machine froze. No blue screen, no shut down; just a complete lock-out. The reset switch didn't work, nor did ctrl-alt-del, so I had to switch off.
I waited a few minutes, switched on again, and behind the graphical corruption that has accompanied these crashes I could see the words 'read error'.
I switched off again, and left the machine overnight.
This morning I tried booting again - no graphical corruption, but still got the read error message.
So I tried booting from the XP CD and going into the console. That took a lot longer than normal, but it worked.
Except I couldn't list the contents of the C: partition of my main drive, and although I could access the D: partition, I got an 'access is denied' message when I tried to access sub-directories.
I'm worried that somehow the main C: partition has become corrupt - but oddly enough, I've not been able to get a directory listing of the second drive in my system, which is a single 15Gb drive labelled E: and I get the same drive read error when I try to list the directory.
I'm probably going to try and reinstall XP again - assuming the C: drive will let me - and if that fails, it looks like I'm going to have to cough up to get the profressionals to look at it.
0
 
LVL 32

Expert Comment

by:Luc Franken
ID: 9881337
Try this one:

How to Manually Remove Windows XP Service Pack 1
http://support.microsoft.com/default.aspx?scid=kb;EN-US;329015

It just sais to make a repair installation from your XP cd-rom
0
 

Author Comment

by:EricCartman
ID: 9882452
No go - I've tried doing a repair to the installation, but the machine won't recognise that there is anything at all on Drive C: (and to correct my earlier posting, I've discovered/remembered that drives C: and E: are on the same physical drive, while drive D: is a separate disk - that's why I can't access either E: or C:)
It seems that the master drive has been trashed, though I've no idea why or how.
I gave up and tried to reformat the drive from the Windows XP disk, but the machine locked up on me again.
Since I can't see any way to progress, I've asked a PC specialist to collect the machine on Monday and see if he can get it sorted.
I'll leave this question open for now, since he may discover that I'm the victim of multiple problems, and if one of them relates to my original query about the Ti4600 I'll post the solution here.
0
 
LVL 32

Expert Comment

by:Luc Franken
ID: 9882667
Ok, Good luck and keep us informed.

Greetings,

LucF
0
 
LVL 6

Expert Comment

by:HippyWarlock
ID: 9940429
I'll be interested in this too, as my ti4600 did the same trick... oddly enough it doesn't now I've installed XP HOME as opposed to PRO, but doubtless it was a driver prob as mine looped after the AGP drivers installed.
0
 

Author Comment

by:EricCartman
ID: 9987329
I posted a comment after accepting an answer and splitting points, but it hasn't appeared.
If this appears, I have one final comment - the card has now been certified 'busted' and Creative have agreed to replace it under warranty.
0
 
LVL 32

Expert Comment

by:Luc Franken
ID: 9987582
Too bad.... at least you got a free replacement ;-) hope this one is working fine for you.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Does your iMac really need a hardware upgrade? Will upgrading RAM speed-up your computer? If yes, then how can you proceed? Upgrading RAM in your iMac is not as simple as it may seem. This article will help you in getting and installing right RA…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now