Solved

BGP redundant  routing

Posted on 2003-12-02
5
630 Views
Last Modified: 2008-01-16
I have two routers each router pointing towards the same cloud network. What I need is if the primary route to one router fails the cloud network needs to know it can route through the other router. Now I'm running bgp on both routers because the cloud network is running bgp. Can I setup an aggregate summary address(summary-only) and a weight on the addresses to accomplish this task. Will the statment below propogate throughout the cloud network. for example

router a:

router bgp 200
network 192.2.2.0
neighbor 10.10.20.1 remote-as 314
neighbor 192.3.1.1 remote-as 315
aggregate-address 192.3.1.0 0.0.0.255 summary-only
neighbor 192.3.1.1 weight 100
neighbor 192.2.2.1 weight 150

router b:

router bgp 315
network 192.3.1.0
network 192.2.2.0
neighbor 10.10.30.1 remote-as 314
neighbor 192.2.2.1 remote-as 200
aggregate-address 192.2.2.0 0.0.0.255 summary-only
neighbor 192.2.2.1 weight 100
neighbor 192.3.1.1 weight 150


  @  @ @@@ @@
     cloud network
@----------------------------------@
|                                            |
|                                            |
@-----------------------------------@
router b                                 router a


Now will this configuration populate the cloud network, so it knows if router a is unavaiable it will route router a's traffic through to router b and vice versa. If you have a better solution let me know...
0
Comment
Question by:Menace212
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 7

Expert Comment

by:NicBrey
ID: 9858986
This is actually quite tricky.
You have two different AS basicly connected with redundant links (via the cloud and with direct link between them). If you do not manipulate the routes properly, you can become transit AS - using your bandwidth to route to other AS through your network.

You only want router A to advertise it's own networks and router B's networks and vice versa.
Your provider also have to configure their BGP routers to accept routes to router A's networks from router B and vice versa.

There are many ways to restrict the BGP updates to neighbors, but I suggest that you work this through with the administrators/engineers of the cloud routers. They might have BGP policies in place that can restrict your options or influence your configuration. If they are running BGP, they should assist their clients in the configuration of their routers

Good luck
Nic







 
0
 
LVL 7

Expert Comment

by:NicBrey
ID: 9859111
Using distribute lists to filter route updates that goes out to a neighbor:

      @ @@@ @@  
     cloud network  (AS 314)
10.10.30.1                                 10.10.20.1
@----------------------------------@
|                                            |
|                                            |
@-----------------------------------@
router b                                 router a
AS 315                                  AS 200
192.3.1.1                               192.2.2.1


Restrictin on router A to only advertise router A and B's networks

access-list 105 permit ip 192.2.2.0  0.0.0.255 host 255.255.0.0
access-list 105 permit ip 192.3.1.0  0.0.0.255 host 255.255.0.0

router bgp 200
network 192.2.2.0
network 192.3.1.0
neighbor 192.3.1.1 remote-as 315
neighbor 10.10.20.1 remote-as 314
neighbor 10.10.20.1 distribute-list 105 out


0
 

Author Comment

by:Menace212
ID: 9860702
So with the distrubute list the cloud network will have 192.3.1.0 and 192.2.2.0 in it's routing table. How would the cloud know if 192.2.2.0 is down then reroute to 192.3.1.0?
0
 
LVL 7

Accepted Solution

by:
NicBrey earned 125 total points
ID: 9864843
If the link between Router A and the cloud went down, the TCP session that holds the neighbor relationship is broken. The cloud should know becasue of the AS path attribute to the AS 200 network that that it receives from Router B.

Here is a link to configuring BGP.
http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800ca763.html

Again, I suggest that you contact the administrators of the cloud routers. Only they can give you the intricate details of the policies that they use on their routers. BGP requires that a TCP session is established between peer routers. If BGP authentication is used on the cloud network,
your routers will not establish these sessions.
0
 

Author Comment

by:Menace212
ID: 9866633
thks
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question