• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1049
  • Last Modified:

Exchange 2000: NNTP Connection Failure

I have setup NNTP connectivity for my Exchange Server (SBS2000) however I get the following event log messages:

The virtual server 1 successfully connected to news.cable.ntlworld.com to initiate a feed.

About 30 seconds later I get :

The virtual server 1 has completed an active feed from/to news.cable.ntlworld.com. Status is FAILURE.

I'm unsure of why this is failing. I have setup logging and the following is the log file entries:


21:28:50 mode ntl+Cablemodem+News+Server+(Typhoon+v2.0.0) 200
21:28:50 date 20031202212737 111
21:28:50 list NewsGroups+Follow 215
21:29:12 newnews NEWNEWS+Permission+Denied+(command+disabled) 502
21:29:12 - - 0


I see Permission Denied, but I'm unsure what this is for. Is it permission denied for the command (command+disabled) or is it permission denied for my connection (I don't have a username and password).

I can connect to the news server using Agent on both client and server so I know connectivity is fine. I have setup the NNTP feed as a Peer feed with both inbound (pull) and outbound (push) access. The newsgroups have actually had their folders created under Public Folders\Internet Newsgroups and a list of the newsgroups have been downloaded as I can see from the Newsgroups section in Exchange Admin.

I've checked the web and no mention of it, so I'm a bit stuck. I think the command that Exchange is trying to use is disabled on my ISP news server, therefore how do I get around it?!?!

  • 2
1 Solution
Using Agent, do you have to authenicate to news.cable.ntlworld.com or does it allow anonomous connections (or screens your IP to see if you are allowed)?
blueivyAuthor Commented:
I don't have to authenticate. I assume it filters by IP address (I'm on a cable modem).
Found these, and I quote;

"The problem I'm finding out is that when the server goes to pull the new messages from the peer it uses a command 'NEWNEWS' to retrieve the list of new messages in the group from the remote server. It appears that most of the news servers leave this command disabled because of the overhead it incurs on their NNTP servers. If this is the case
you'll probably see something like 'newnews, NEWNEWS+Permission+Denied+(command+disabled)' in your nntp logs. "

"Most Newsgroup Servers have the "NEWSNEWS" command disabled so they are not overwhelmed by requests from anyone running their own exchange NNTP service. News clients however use the "XOVER" command to initiate transfer, and no there isn't a way to get exchange to use that command."

I would contact ntlworld and ask for support, then ask the tech if they have a way of allowing Exchange server access


Note the "-b true | false Indicates whether the Newnews command is allowed. " section. The problem you have is the NEWNEWS command that Exchaneg uses, and your ISP ignores.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now