Can not flush the DNS Resolver Cache.

I have Windows XP. Whenever I type "ipconfig /flushdns" I get "Could not flush the DNS Resolver Cache: Function failed during execution."  The reason I am trying to flush the DNS cache is because www.google.com and some other popular sites are no longer work. I have tried running both McAfee and Ad-aware and my computer is supposedly clean of any virus/spyware. Any help would be appreciated!!
flaffeboyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

qwaleteeCommented:
Check the C:\WINDOWS\SYSTEM32\DRIVERS\ETC\HSOS file (no extension on the HOSTS filename; and it might be C:\WINNT instead of C:\WINDOWS).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chicagoanCommented:
sounds like spyware

check out
http://www.spychecker.com/spyware.html

SpyBot-S&D is my fave
0
stevenlewisCommented:
found this
I had the DNS Client stopped. I started it and ran ipconfig /flushdns again and this time it worked.
and while I'd vote on the hosts file, also found this
By default, the resolver accepts responses even from servers it did not query. This could present a possible security liability, as an unauthorized DNS server might pass along invalid resource records to misdirect DNS queries. This can be avoided by adding a DWORD value named QueryIpMatching with a value of 1 to the following location in the registry: HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ Tcpip \ Parameters
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

bbaoIT ConsultantCommented:
0
Sebo2000Commented:
try that it worked once for me:

1.      Open Registry Editor on a server with a DNS client service

2.      Go to HKEY_LOCAL_MACHINE on Local
Machine>System>CurrentControlSet>Services>Dnscache

3.      On the file menu select Registry>Save Key and Browse to a location to save
the file to and give it a File name, then click Save

4.      Copy the file saved to the server without the DNS client service

5.      Open Registry Editor on the server without the DNS client service

6.      Go to HKEY_LOCAL_MACHINE on Local Machine>System>CurrentControlSet>Services
and on the File menu select Edit>Add Key.  Type Dnscache for the Key Name and
click ok.

7.      Go to HKEY_LOCAL_MACHINE on Local
Machine>System>CurrentControlSet>Services>Dnscache

8.      On the file menu select Registry>Restore Key and then browse to the location
of the saved file.  Select the file and click Open.  Click OK on the Restore.

9.      Reboot the server without the DNS client service

10.      Go to Start>Programs>Administrative Tools>Services.  Look for the DNS
client service.  It should show up now.
0
yakcoraCommented:
FixQhost.exe this is what you need you have a BHO

check your c:\windows\help\ folder if you have a hosts file there delete it and reboot. if it is not there search for "hosts" in your drives delete all except c:\windows\system32\drivers\etc <-- this is the real one

0
bbaoIT ConsultantCommented:
sorry, could you tell me what is BHO?
0
chicagoanCommented:
Browser Helper Object = SPYWARE
0
bbaoIT ConsultantCommented:
o, i see. thanks. :)
0
bjravishankarCommented:
Deleting hosts and lmhosts, changing the registry settings might help. But an other solution would be to create a new user account in case of a client system in a standalone or workgroup computer. it can be resolved
0
malhyCommented:
1. Click Start, click Run, type services.msc, and then click OK.
2. In the list of services, click DNS Client.
3. Make sure that the Status column displays Started and that the Startup Type column displays Automatic.
4. If the service is not set to Started or if the startup type for the DNS Client service is not set to Automatic, follow these steps:a.  Right-click DNS Client, and then click Properties.
b.  In the DNS Client Properties dialog box, click the General tab, and then click Automatic in the Startup type list.
c.  Click Start, click Apply, and then click OK.
 
0
Ionut A. TudorPHP ProgrammerCommented:
thanks malhy for services.msc, i disabled long time ago the DNS client, and now when i needed to flush it didn't worked. I put it on automatic and started it and it successfully flushed the DNS. Cheers
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.