[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Access runtime error 2455 mystery

Posted on 2003-12-02
16
Medium Priority
?
2,736 Views
Last Modified: 2010-08-05
Hello,

I have about 5 mdb files that contain programs and data, links to data, etc. that I have been using for years with Windows 98, Access 2000.  After a few months of fine tuning, everything worked without problems when I switched to Windows XP, Access 2002.

Suddenly, when I open any of these modules and compile any new code, I receive the error "Runtime Error 2455", "You entered an expression that has an invalid reference to the property "xxxx".  (The "xxx" usually being the first referenced after opening the module - e.g.: .visible, or the use of a function as Time(), Date(), etc.)  Sometimes the "xxx" refers to a property that I'm not even using in the code.

Help!
0
Comment
Question by:jmcclax
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 4
  • +1
16 Comments
 
LVL 23

Expert Comment

by:heer2351
ID: 9862954
You might have a missing reference, open any module in design view -> Tools -> References

Check if any is reported as missing.
0
 

Author Comment

by:jmcclax
ID: 9863011
I t hought the same thing, but no references are reporting missing.
0
 
LVL 9

Accepted Solution

by:
svenkarlsen earned 1000 total points
ID: 9863035
Jmc,

smells bad....

If Time() and Date() results in compile errors, it's normally something else, - but do look for missing references as suggested by heer2351.

XP: have you added hotfixes and latest SP? (don't believe them when they call everything "Security Updates", - there's bits and pieces in those too;-)

The migration from 2000 to 2002: did you just update? Did you compress/repair the 2000 version before update ?

Anyhow, - the path to problemsolving a case like yours is normally:

1. Create an empty Db in 2002
2. Import objects 1 at a time, compiling between each import untill you detect the culprit!


Sven
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 
LVL 23

Expert Comment

by:heer2351
ID: 9863041
First of all you are up to date on the service packs, SP2 for Access XP.

Can you compile your database? Is it pointing you to a line of code that is indeed incorrect?

0
 

Author Comment

by:jmcclax
ID: 9863067
Yes, up to date on service packs and security updates.  I even tried uninstalling and reinstalling all in the event that the service packs or security updates were the culprit (that, anyway, had been done about 1 month ago and all was well until yesterday).
Did not covert to 2002.
All code was correct and worked just fine until yesterday.  No code has been altered for 6 months.  
When you suggest to create a new db and import until I detect culprit, are you saying that all 5 modules have to have this done to find a solution?  No code changes have been made for 6 months to any of the modules.  It sounds more to me like some sort of Access/system problem, no?
0
 
LVL 23

Expert Comment

by:heer2351
ID: 9863086
It could also be an ActiveX problem, one of the usual suspects is the COMDLG32.OCX. Any changes made to that respect?
0
 

Author Comment

by:jmcclax
ID: 9863118
Would updating Microsoft Windows media player have affected that?  If so, yes.
0
 
LVL 9

Expert Comment

by:svenkarlsen
ID: 9863119
jmc,

my bet would normally be on the database in your case, but we can focus on the system for a start if you like:

Uninstall & re-installing Office didn't always produce the desired result in Office 2K, and I'm not sure if the same  problems do not persist in XP, so if you like you can try an trick of mine and see if it works on XP too (it has handled some, but not all, Office related problems in the past for Word and Access).

The basic feature is that it really does an overwrite of everything, in stead of trying to guess if everything is ok:



Office 2K Critical repair procedure:

This procedure is based on the following refs:
      http://support.microsoft.com/default.aspx?scid=kb;en-us;230672&Product=ofw2k

1. Close all programs (ALL!)

2. Revert installation to original files for all:
      open a cmd-box
      cmd-line: <CD-ROM Drive-letter>:\setup.exe /fdum data1.msi

      - this will overwrite any file that isdifferent from the original media
        and reset registry keys to original

3. Re-apply all service-packs and updates

(please don't feel offended by the low-level approach, - I wrote it for some newbies once ;-)

Anyhow, - if this doesn't do the trick, I suggest you focus on the New Db/Import procedure, - it really isn't that tedious.

Sven
0
 
LVL 23

Expert Comment

by:heer2351
ID: 9863153
Sven I have to leave it into your capable hands.
0
 

Author Comment

by:jmcclax
ID: 9863154
Ok, I'll try the repair option.
One question regarding the new db/import suggestion.  Since none of the code has been changed in 6 months, what exactly could that method point me to?
0
 
LVL 9

Expert Comment

by:svenkarlsen
ID: 9863510
jm,

always hard to tell, but sometimes it identifies a module where some code - which used to be valid with e.g. the Jet 3.5, isn't valid with Jet 4.0, and sometimes it simply fixes itself ;-)

I know it sounds like  alchemy (sp?), but it actually is one of the most used tolls for handling "suddenly appeared problems" with Access.

The reason that I bring it up in an early phase of the error-search, is because your initial statements sounded as if you are a carefull person who don't just hack around in your modules, - if that had been the case, I'd have suspected you before the system ;-)

But, as it is, I'm hearing 6 bells from the clock, telling me that European Standard Time is 3 o'clock morning, so I will not be able to comment further for the next 10 hrs. or so.

Kind regards,
Sven
0
 

Author Comment

by:jmcclax
ID: 9870999
Sven,

I resolved the problem last night.  When I created a new database as you suggested, I noticed
that one of the references that was automatically checked in the new database (ActiveX library 2.1) was one that I had not been using before. When I left that reference checked, the problem went away.

I am baffled by this, as everything was running great until a few days ago, and no code changes have been made for months.  I don't understand what the ActiveX library's purpose in my projects would be for, anyway.  Is this some new requirement in XP?

Thank you very much for your help,
John
0
 

Author Comment

by:jmcclax
ID: 9871006
heer2351,

Thank you for your help, too!

John
0
 
LVL 9

Expert Comment

by:svenkarlsen
ID: 9871429
jm,

well, - as I said (or did I?): Access isn't always an exact science, so you learn that the procedures that may seem supersticious at first glance (like the New Db/Import) often helps in unexpected ways ;-)

Glad you got it solved!

Sven
0
 
LVL 23

Expert Comment

by:heer2351
ID: 9876738
Microsoft ActiveX Data Objects Library 2.1 is called in short ADO. ADO is the new default data access method for access 2000 and up, it replaces DAO.
0
 
LVL 9

Expert Comment

by:ornicar
ID: 10075635
----------------------------------------------------------------------------------------
This question has been abandoned and needs to be finalized.
 You can accept an answer, split the points, or get a refund (information at http:/help.jsp#hs5)
  If you need a moderator to help you, post a question at Community Support (http:/Community_Support/)

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

ornicar
Cleanup Volunteer

---------------------------------------------------------------------------------------------
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Did you know that more than 4 billion data records have been recorded as lost or stolen since 2013? It was a staggering number brought to our attention during last week’s ManageEngine webinar, where attendees received a comprehensive look at the ma…
Instead of error trapping or hard-coding for non-updateable fields when using QODBC, let VBA automatically disable them when forms open. This way, users can view but not change the data. Part 1 explained how to use schema tables to do this. Part 2 h…
Learn how to number pages in an Access report over each group. Activate two pass printing by referencing the pages property: Add code to the Page Footers OnFormat event to capture the pages as there occur for each group. Use the pages property to …
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question