Extracting individual file from tape remotely

can someone provie the syntax to retrieve a file from a remote tape drive using either dd or tar/rsh.I am using Solaris8.
ranadhirAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ranadhirAuthor Commented:
I just need to extract an individual file from the zipped archive,and not the entire archive.
0
mbekkerCommented:
Hi ranadhir,

If it's a tar archive you could try the following:

rsh <hostname> "dd if=/dev/<tape_device> bs=512" | tar xvf - <file_to_extract>

There's only one problem, the complete archive will be send through the network.

You could also extract the file on the remote system and use a remote copy to copy the file to the local system. Only data from that file will be send over the network:

rsh <hostname> "tar xvf /dev/<tape_device> <file_to_extract>"
rcp -p <hostname>:<path>/<file_to_extract> <local_path>/<file_to_extract>

Good luck!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ranadhirAuthor Commented:
Thanks a lot for the suggestion.Since the 'tar xvf' does not accept pattern matching - I am doing a
tar xvf /dev/rmt/0 `tar tf | grep '<pattern>'` on the machine to which the tape is attached.
Can this same command be fired with the rsh option from a remote machine(using pattern matching facility of tar)
0
mbekkerCommented:
It should work. The only problem I see is the rcp part, this should be changed in something like this:

rcp -p <hostname>:<path>/<pattern> <local_path>

So, without the <file_to_extract> part.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.