BT Megastream & Cisco

We've got a 2Mbps megastream from BT, and now want to know how we can connect the two ends to our two networks using Cisco routers :-)

The routers connect to the megastream wall boxes using X21 cables

Has anyone got an example configuration of how to do this in IOS?



LVL 5
pscsukAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

chicagoanCommented:
You should get the line parameters from the provisioner.
Once you've got that, you need know what protocols you want to route and what the address ranges in each location are.

0
MaBCommented:
I assume you will connect the X21 cables to the serial0/0 interface on the routers. What routing protocol are you using? OSPF?
0
pscsukAuthor Commented:
Line parameters? What sort of thing are we looking for?
(It uses frame-relay encapsulation, not sure what else we need to know)

The X21 cables are connecting to the serial0 interface on the routers.

We're wanting to route IP, with address ranges 192.168.57/24 on one network, and 192.168.55/24 on the other

Routing protocol? For the start I was just going to use static routing tables, which is what I've done on a kilostream-N connection to an ISP before.

The problem I'm having at the moment is that when I do 'show int ser0' I get something like this:

Serial0 is up, line protocol is down
  Hardware is PowerQUICC Serial
  Internet address is 192.168.65.1/24
  MTU 1500 bytes, BW 2048 Kbit, DLY 20000 usec,
     reliability 253/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, loopback not set
  Keepalive set (10 sec)
  LMI enq sent  765, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down
  LMI enq recvd 1, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
  FR SVC disabled, LAPF state down
  Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
  Last input 00:00:03, output 00:00:08, output hang never
  Last clearing of "show interface" counters 02:07:38
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1536 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     772 packets input, 10036 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     138 input errors, 0 CRC, 133 frame, 0 overrun, 0 ignored, 5 abort
     771 packets output, 10791 bytes, 0 underruns
     0 output errors, 0 collisions, 254 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

pscsukAuthor Commented:
>(It uses frame-relay encapsulation, not sure what else we need to know)

Actually - thinking about it.. Does it? Or, does it use HDLC or something else?
0
chicagoanCommented:
5 minute output rate 0 bits/sec, 0 packets/sec
     772 packets input, 10036 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     138 input errors, 0 CRC, 133 frame, 0 overrun, 0 ignored, 5 abort
     771 packets output, 10791 bytes, 0 underruns
that doesn't look too hot...
once you get that line up:

Serial0 is  192.168.65.1/24 on this side, make the serial0 on the other in the same subnet

192.168.57/24 on one network, and 192.168.55/24

ip route 192.168.55/24 192.168.65.1 on one side

ip route 192.168.57/24 192.168.65.2 on the other
0
pscsukAuthor Commented:
Nope, I know it doesn't look too hot..

Serial0 on this router is 192.168.65.1/24, on the other side it's already 192.168.65.2/24

I haven't got around to the 'ip route' lines, because I wasn't convinced they were actually talking on the line...

Should I be able to PING one router from the other - eg from 192.168.65.1, should I be able to log on to the router, and type 'ping 192.168.65.2' - this would test the line without caring about the routing settings.

I've assumed I should be able to do this, but it doesn't work at the moment, and the 'line protocol' is always down (sometimes it goes 'up' but as soon as I try to ping the other router, it goes down again..)



0
chicagoanCommented:
>Should I be able to PING one router from the other
with the config you posted, yes

but you have to get the line parameters from the provisioner and get it up 1st
0
pscsukAuthor Commented:
But what do you mean by 'line parameters'?
BT don't seem to know what I mean if I ask them that question. It's essentially an E1 line - a 2Mbps, private digital circuit.

What sort of parameters am I trying to find out?

Paul
0
td_milesCommented:
Try talking to BT and asking them what sort of card you need and how it should be configured. I am in AU and we installed a leased 2MB service about 12 months ago and it used G.703, so we needed a different WIC for our router (not a normal E1 WIC). Ours was "essentially" an E1 line as well, but it wasn't standard E1.

Once we had the correct card, the configuration was remarkably simple:

==========
controller E1 0/0
 channel-group 1 unframed
!
interface Serial0/0:1
 ip address x.x.x.x 255.255.255.252
!
==========

and that was it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chicagoanCommented:
you wouldn't have thought my blood worth bottling had I tried to guess that...

and so... the routing issue?
0
pscsukAuthor Commented:
Thanks, td_miles

This definitely should be X21 - a BT engineer is coming today for a different thing, so I'll ask him just to check that their box is set for X21 not G703, as it is capable of either, and could have been set up incorrectly, and one end does seem to be behaving differently from the other...

I guess the 'controller' command is part of IOS for a different router than we have - it doesn't seem to be there on our 1721

I wonder if I'm just trying to make life too difficult.. I'm going to take out my 'encapsulation' commands on the serial0 interface and see if it 'just works' :-)

(Setting up the routing isn't going to be a problem - I've done that lots of times, it's the 'talking on the line' which is the tricky bit)

0
pscsukAuthor Commented:
Thanks td_miles - it's now solved.

I was just trying to make life too complicated...

Your
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
interface Serial0
ip address x.x.x.x 255.255.255.252
!
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

information was all I needed.. :-)

Now, it works, and the routing I've set up all works fine as well, so I'm happy :-)

(And I still don't know what 'line parameters' I needed to find out...)

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.