Unbuffered NFS on FreeBSD

I have a process running on a Solaris 2.6 server that writes continuously to a log file. This log file is sitting on an NFS filesystem (hosted by a network application storage filer) which is mounted read-only on a FreeBSD server.

There's a process running on the FreeBSD box that's supposed to read each line as it comes in and add some information about it to a berkely DB file stored on the machine's local disk. Ideally, I'd like the entire process (writting to log -> read log -> add to database) to take a few seconds at most. It currently takes around a minute.

If I tail -f the log file on the Solaris box, I can see the writes happening live, as they happen. If I tail -f the same log file on the FreeBSD box, I see nothing new happening....then about a minute later my console gets flooded with new entries....then nothing for a minute.....then another influx of data.

I think what's happening here is somewhere, the NFS traffic is being buffered by the OS. The only mount options I'm using on the FreeBSD box in /etc/fstab for this partition is 'ro' (read-only). Is there anything else I can do to ensure that the OS itself is not buffering the incomfing NFS traffic? Any sysctl switches that I can tweak?

Thanks for any help you can provide.
seagu11Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

seagu11Author Commented:
Geez. Sorry, I meant to say the NFS server is a "Network Appliance" filer.  (Netapp). Not a Network Application filer....
Fingers went on autopilot there I guess. :)
0
gheistCommented:
most likely you will tweak -r and -w parameters for mount_nfs and maybe noac for nfs misses new attributes, and adjust -a parameter according to your filesizes and reads - the larger -a the larger sequential preread, the worse database and small file performance.

i.e in /etc/fstab:
.. .. .. ro,-r32768,-w32768,noac,-a0
0
gheistCommented:
manual for mount_nfs is very handy:

BUGS
     Due to the way that Sun RPC is implemented on top of UDP (unreliable
     datagram) transport, tuning such mounts is really a black art that can
     only be expected to have limited success.      For clients mounting servers
     that are not on the same LAN cable or that tend to be overloaded, TCP
     transport is strongly recommended, but unfortunately this is restricted
     to mostly 4.4BSD servers.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
seagu11Author Commented:
THanks for your pointers.

This actually ended up being resolved by properly synching the time between all involved servers and the filer. They weren't using the same ntp host (and some weren't doing ntp at all).

Sillyness.

Guess I was barking up the wrong tree.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.