rsh problem from redhat9 to solaris 2.6 - protocol failure

  When I tried to connect with rsh to solaris 2.6 machine from my redhat 9.0 machine I had a problem.
  For example a simple command :
     [operator@ldw1 tmp]$ rsh scmssrv1 "ls"
     poll: protocol failure in circuit setup

   When I tried exactly the same thing from a redhat 8 machine there is no problem. The unix machine same and rlogin works for both redhats.
   I tried to install and use the same rsh and rsh-server packages on the redhat machines but there was no change.
   There is no firewall. Only a soft linux router with some little firewall configuration and as I said rlogin is working on the machine properly.
   Both redhat machines are on the same swith and same network. The network configuration for both machines ( Two redhats = 1 woks the other not) are exactly same.
   Thanks for your help.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

it looks like firewall problem.

open your port 1021-1023 for internal network.
u can also try just
running rsh scmssrv1, and i think it should work.
Modify /etc/inetd.conf to allow more processes per minute for rsh.

shell      stream      tcp      nowait      root      /etc/tcpd2      in.rshd
shell      stream      tcp      nowait.200      root      /etc/tcpd2      in.rshd

C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

also add your hosts to /etc/hosts.equiv file.
kelesAuthor Commented:

  rsh scmssrv1 is running but what does it mean. I still cannot execute it with any simple command. I tried the other ways already but only I didn't open the ports 1021- and 1023. How can I understand if they are open or not. And when I activate rsh deamon on redhat it works properly. I have problem only when redhat 9 tries to connect and execute a command on solaris 2.6 with rsh. In the all other case it works. With which command I can make the same thing.
do u have .rhosts files on both the server.
and u have want to place + in .rhosts files.
solaris need this file in place on its server to work rsh.
kelesAuthor Commented:

  Of course I have the .rhosts file on the server side. As I said before it is working on an other release of redhat. Let me explain again:

   Redhat 8.0 sends "rsh scmssrv1 ls" to Solaris 2.6(scmssrv1) = it's working
   Redhat 9.0 sends "rsh scmssrv1 ls" to Solaris 2.6(scmssrv1) = it's not working ( As I said it gives a strange message "poll: protocol failure in circuit setup"
   Redhat 9.0 sends "rsh scmssrv1" to Solaris 2.6(scmssrv1) = it's working

   Redhat 8.0 and Redhat 9.0 are on the same network and switch. They have the same login users with the same uids and etc. They have same hardware. Only difference is operating system that I know.
    And thanks for your interest.
kelesAuthor Commented:

  Finally I found a hardware problem on the ethernet cards. So problem was solved.
Good to know you got the issue resolved. You can close the question by following this guidelines:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.