Running Bugzilla get Perl compilation error can't locate data/params in @INC

RH3.0, Bugzilla 2.16.4, post configuration perl script, when loading index.cgi into a browser I get the following:

Software error:

Can't locate data/params in @INC (@INC contains: . /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl) at globals.pl line 1448.

For help, please send mail to the webmaster, giving this error message and the time and date of the error.
Software error:

[Wed Dec  3 09:02:20 2003] index.cgi: Can't locate data/params in @INC (@INC contains: . /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl) at globals.pl line 1448.
Compilation failed in require at /var/www/html/bugzilla-2.16.4/index.cgi line 38.

For help, please send mail to the webmaster, giving this error message and the time and date of the error.
gbpennAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jmcgOwnerCommented:
I think you may have been bitten by a variant of this bug:

http://bugzilla.mozilla.org/show_bug.cgi?id=139930

In any case, you need to create a data/params file in the Bugzilla directory. It may be possible to get started by loading editparams.cgi directly in your browser rather than index.cgi -- I don't have a way to check this.

Does running the ./checksetup.pl script produce anything interesting?
0
gbpennAuthor Commented:
No, this was not the issue.  The answer lies here: http://ricardo.ecn.wfu.edu/~plug/mail_archive/0101/0306.html

A path was required to manually add to the @INC variable.  Once it found the files then I encountered a permissions problem (these seem to be rampant in Bugzilla but this is for internal dev anyway so I just opened it up).

Now I'm getting another error:
Software error:

LOCK TABLES shadowlog WRITE,  tokens WRITE: Table 'bugs.shadowlog' doesn't exist at globals.pl line 279.
0
jmcgOwnerCommented:
I've not installed Bugzilla, so I don't have a basis for true expertise. From what you're encountering, I'd have to say that is is "not ready for prime time" if you have to do a lot of undocumented configuration and debugging to get it to work.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

ultimatemikeCommented:
I would like to point out that your version of RH (and the kernel) is quite old. Although this may not be causing the problem, it is also a possibilty.
0
gbpennAuthor Commented:
The version of RedHat I'm running is the newest release available on the market today.  I should have better defined, this is Red Hat ENTERPRISE version 3.0, using the 2.4+ enterprise kernel with some instructions included from the 2.6 kernel yet to be released.

This is a known, stable product.  Sorry for the miscommunication.

Per the prior comment about "not ready for prime time" are you aware that Bugzilla is:
1) The industry standard bug tracking application on the market and open source
2) Used by the likes of Mozilla foundation, RedHat and IBM?
3) Based on that argument none of us should be running FreeBSD, WebLogic or any other complex application to setup because they "might not be ready for prime time". :)  

Either way, the issue is now resolved.  The answer was to modify some parameters in the checksetup.pl file, then re-run it after manually removing the (evidently) corrupted MySQL database.  This cleared up all db issues.  I ran into a few additional issues with permissions but have since resolved them.

Thanks for everyone's help and input.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jmcgOwnerCommented:
Sure, I'm aware of those things about Bugzilla. I've _used_ Bugzilla. I watched from a distance as a colleague struggled to get it installed and running the way he wanted. I'll stand by the assessment of "not ready for prime time". It's a tool that needs a savvy person like him or you to get it installed and working. That's not the "prime time" audience. Based on the way you asked your questions here, I was still trying to figure out if you were a member of that audience or not.

Now that you've solved this question, I recommend you go to Community Support and request that a moderator PAQ this question and refund your points.
0
jmcgOwnerCommented:
I had suggested that the question be PAQed. I don't think we did anything that should be rewarded with points, but I'd like to see this question stay in the database.
0
gbpennAuthor Commented:
GhostMod, my post asked for a refund of points, NOT deletion, just to clarify.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Perl

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.