• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 607
  • Last Modified:

suexec with Redhat 9.0

First, I recently switched from Mandrake to Redhat 9.0 and httpd-2.0.40-21
I am trying to run a script which requires root privileges.  
The script is located in /var/www/cgi-bin/

I ran chmod a-s myscript.cgi to my script

In my httpd.conf I have
User apache
Group apache
So I ran the following commands:
chgrp apache /usr/sbin/suexec
chmod 4750 /usr/sbin/suexec
(It says to do this at http://httpd.apache.org/docs-2.0/suexec.html)

I have added the following line to httpd.conf:
LoadModule suexec_module modules/mod_suexec.so

When I start apache, I get the following in my error log:
[Wed Dec 03 15:25:26 2003] [notice] Apache/2.0.40 (Red Hat Linux) configured -- resuming normal operations
[Wed Dec 03 15:26:18 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)


I have found a thread with a similar problem, but their solution was to install a src rpm.  I would prefer to not have to reinstall.

Thank you for your time.
0
DontLookDown
Asked:
DontLookDown
1 Solution
 
jerkface2098Commented:
Make sure you have the perl-suid rpm installed.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now