Frontpage 2003 Bug?? Cellspacing

Is anyone else having this problem or only me.
When creating a table, if modifying the cellspacing = 0 and cellpadding = 0...
why does frontpage not insert the cellspacing = "0" into the html code?? but does insert cellpadding = "0"???

LVL 2
RickDaiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RanjeetRainCommented:
HTML standards demand that.
0
RanjeetRainCommented:
Let me explain.

Any entity, which is a non keyword, has to be quoted as per HTML standards. So, be it whatever value you assign, it has to be inside double quotes.
0
RanjeetRainCommented:
CELLSPACING = 0

Works but is NOT compliant.

CELLSPACING = "0"

Complies to HTML standards.



BACKGROUND = RED

Works but is NOT compliant.

BACKGROUND = "RED"

Complies to HTML standards.
0
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

seanpowellCommented:
???

Hi RickDai,

To answer your question - it's not "exactly" a bug in FP2003. Because the cellspacing attribute doesn't exist in the CSS spec - it aooears that they decided not to have it created in the html code automatically - in the same way that previous versions did.

So - the fastest option is to give cellspacing an attribute of 1, and then simply change it to 0.

Thanks,
seanpowell
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RickDaiAuthor Commented:
seanpowell,

yup thats my problem... ahh damn does that mean extra work for me... lol. any quicker solution besides changing the atrribute to 1 then to 0 again?
0
RickDaiAuthor Commented:
RanjeetRain, you've mistaken my question/problem.
0
seanpowellCommented:
Not that I'm aware of. If you insert the table into the page while you're in html view, and still don't get the cellspacing attribute - then there's probably no way to speed up the process. I've used their demo quite a few times and never experienced that behvaiour - so it's very likely that it's particular to your specific OS/FP version. If you're using the beta that may be having an effect...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development Software

From novice to tech pro — start learning today.