DNS issue


I would like to ask a question about DNS.
There are a few users that are unable to resolve the machine name which  are residing in the DNS. What might be the cause of the problem?

I tried to set up a senario by having two identical machines .
One mahcine is able to resolve the machine name from DNS (no host file is needed) but the other can't resolve the machine name from DNS. That machine also can't perform a NSLOOKUP but able to resolve internet URL.

What might be the cause?

I am using Win2K for my DNS.

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pete LongTechnical ConsultantCommented:
What is the OS of your two test clients if one of them is windows 9x I suggest installin the WINS service on the server

Hi angls,
Looks like the second machine doesn't have TCP/IP set up properly. Suggest you look at the TCP/IP settings and ensure that the DNS server is the same in both cases (Your Win2K DNS server).

Regards .. Alan
Pete LongTechnical ConsultantCommented:
On the machine thats failing is it displaying the correct DNS server when you

2K/XP Start >run >cmd >ipconfig /all
95/98 Start >Run >command >winipcfg

If itd a 2k/xp machine try Start >run cmd >ipconfig /flushdns and try again

also check the DNS forward lookup zone to make sure there arnt multiple entries for the same clients

CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

one possibility....for the clients with the problem, is their DNS domain set to the same as the one the DNS server is using?
If they're trying to resolve using just the host name, try using the address using the FQDN (host name + domain name) and see if that works....

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
anglsAuthor Commented:

Both the clients machines are on Win XP. Strangely one of it works. When does a ipconfig. all the setting are similiar. We dont have a WINS in our enviroment and will not be setting a WINS service.

anglsAuthor Commented:

Thanks for all the comments. I have found out the reason for not having resolve on one of the client machine. It is due to the DNS suffix which was put wrongly at the TCP/IP advance setting

and you discovered that because when you pinged the FQDN (as I suggested) it worked? :)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.