ndl file only works when notes is closed

I have a problem with opening ndl files on some PCs. I don't know if this is OS related or just settings somewhere but so far the ndl file will work fine on Windows XP but not on 2000 or 98.
On these systems the ndl file will only work if notes is closed. If notes is open it will go to a notes error message of 'File does not exist'.

ndl file is correctly associated - proven by opening when notes is closed
registry settings on HKEY_CLASSES_ROOT\notes match on each system

Help would be greatly appreciated
Mel_gAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

HemanthaKumarCommented:
This might be related to space in the file path !!
I don't know why XP does this better, but if you have space int the file path then this will fail.

Eg: C:\Temp Documents\my.ndl will not start notes, but C:\TempDocuments\my.ndl does !

~Hemanth
0
HemanthaKumarCommented:
And there seems to be a workaround descibed in this article

http://www-1.ibm.com/support/docview.wss?rs=899&uid=swg21100073
0
Mel_gAuthor Commented:
No it's not related to spaces - I tried the fix although this says it will not open when notes is closed - mine will not open when notes is open.
I also tried putting the link directly in the c drive and it gives the same error there
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

qwaleteeCommented:
I would definitely re-install Notes.
0
Mel_gAuthor Commented:
most of these are new installations - has anyone had this working properly with windows 2000?
0
qwaleteeCommented:
Not with win2k, but with both XP and NT4.
0
qwaleteeCommented:
What version of otes are you running?
0
Mel_gAuthor Commented:
have tried with both 6.0.2 & 5.0.6
0
qwaleteeCommented:
I wonder... Notes is started in two stages.  NOTES.EXE is called, which processes the command line, checks if NLNOTES.EXE is alread runing, starts it if necessary, and if necessary tells the new or existing copy to perform an action.  NLNOTES.EXE really only accepts a database name on the command line.  All the other command line options -- MAIL to open mail, passing NDL files, etc., is controlled by NOTES.EXE.

If you set up Windows to call NLNOTES.EXE on an NDL file, I would expect some sort of error.  Or, if NOTES.EXE is replaced by NLNOTES.EXE.  Or you have the worng version of NOTES.EXE.
0
Mel_gAuthor Commented:
I tried with both opening with notes.exe and nlnotes.exe, with nlnotes I got an error saying process already running - usual error with notes. I then tried opening nlnotes and tried each again with the same errors on each
0
qwaleteeCommented:
You tried using the command line to open the NDL file, identical command lines from identical starting directories, the command line looking something like C:\Notes\NOTES.EXE C:\TestFile.NDL -- correct?

Do you have a "plain vaniall" install?  Meaning, only one copy of Notes has ever been installed on the machine, not via upgrade, and using the standard Lotus installation routine, not a customized one?
0
Mel_gAuthor Commented:
No - I didn't use the command line, I changed the file association to open with nlnotes or notes.
I have now tried with the command line and it opens correctly
It is a vanilla install - most of these machines are brand new newly installed W2K and newly installed notes 6.0.2 with standard installation
0
Mel_gAuthor Commented:
With this new information can anyone help with a solution?
0
qwaleteeCommented:
OK, let me get this straight.  If yuo use a command line to open the file (NOTES.EXE X:\Y\NDLFILE.NDL) then it works, whether Notes is open or closed.

But, f you just try to "launch" the NDL, it only work if Notes is closed?

Go to the folder properties, and look up what NDL hinks it is asociated with, what the default open type is, and what settings are used there.  You can also use the registry to browser to HKCR\.ndl\Shell\Open\Command
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mel_gAuthor Commented:
Sorry for the delay in responding. Adding that entry to the registry appears to sort the problem on some machines but not on others - although mostly solves it.
I now am having a delay in getting to other machines where it is not solving the problem. It appears that it is to do with associated registry entries though.
As this will take time to get access to all machines and I'm confident we can find different entries, I will happily accept your answer along with my thanks for not giving up on the problem
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Lotus IBM

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.