Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Ping works fine to an IP address, but fails to resolve to a DNS address

Posted on 2003-12-04
17
Medium Priority
?
956 Views
Last Modified: 2010-03-18
Scenario:

I've seen this a few times as I'm a head technician and the only resolve I've had in the past was a reload of windows.  Thought I'd try and see if anyone else has seen this and found a solution.  

Here is a copy of the command prompt status that may help explain the difficulty of this problem:

==========================================================================
C:\Documents and Settings\Nancy>ping 12.166.20.10

Pinging ► with 32 bytes of data:

Reply from 12.166.20.10: bytes=32 time=343ms TTL=64
Reply from 12.166.20.10: bytes=32 time=169ms TTL=64
Reply from 12.166.20.10: bytes=32 time=168ms TTL=64
Reply from 12.166.20.10: bytes=32 time=167ms TTL=64

Ping statistics for Où♠:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 167ms, Maximum = 343ms, Average = 211ms

C:\Documents and Settings\Nancy>ping www.comwares.net
Ping request could not find host www.comwares.net. Please check the name and tr
 again.

C:\Documents and Settings\Nancy>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : nancysputer
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

PPP adapter CWI 56k - Paris:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
        Physical Address. . . . . . . . . : 00-53-45-00-00-00
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 12.166.20.150
        Subnet Mask . . . . . . . . . . . : 255.255.255.255
        Default Gateway . . . . . . . . . : 12.166.20.150
        DNS Servers . . . . . . . . . . . : 12.166.20.10
        NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Documents and Settings\Nancy>telnet 12.166.20.10 80
Connecting To 12.166.20.10...Could not open connection to the host, on port 80.
The requested service provider could not be loaded or initialized.


C:\Documents and Settings\Nancy>telnet 12.166.20.10
Connecting To 12.166.20.10...Could not open connection to the host, on port 23.
The requested service provider could not be loaded or initialized.
==========================================================================

**Where the "Square" is, a symbol of an arrow pointing to the right shows up.

It seems that I've seen this when AOL 8 Plus has been installed on an XP Home version, but I don't know that is the case.

I have reset the IP interface several times with the log showing the below results:

=======================================================================
reset   SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_{35B1E4A3-BFDC-49A0-84FB-4FA94B269E06}\NetbiosOptions
            old REG_DWORD = 2

reset   SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_{B54ADB43-85CB-4E96-AD0C-2D04A5E90386}\NameServerList
            old REG_MULTI_SZ =
                <empty>

reset   SYSTEM\CurrentControlSet\Services\Netbt\Parameters\Interfaces\Tcpip_{B54ADB43-85CB-4E96-AD0C-2D04A5E90386}\NetbiosOptions
            old REG_DWORD = 2

deleted SYSTEM\CurrentControlSet\Services\Netbt\Parameters\EnableLmhosts
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{B54ADB43-85CB-4E96-AD0C-2D04A5E90386}\NameServer
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DontAddDefaultGatewayDefault
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableIcmpRedirect
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableSecurityFilters
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SearchList
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\TcpMaxDataRetransmissions
deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\UseDomainNameDevolution
<completed>
========================================================================

**This log didn't seem to look like the others I have done in the past.


Any help would be appreciated as it seems I run into this problem about once every quarter or so.

Thanks guys!

Blaze
0
Comment
Question by:blazetaylor
16 Comments
 
LVL 16

Expert Comment

by:JammyPak
ID: 9875758
I'm not sure why the telnet attempts aren't working, but for DNS problems I would try this first:
ipconfig /flushdns
ipconfig /registerdns
0
 

Author Comment

by:blazetaylor
ID: 9882534
Trust me on this, it wasn't a simple DNS problem.  The Application layer on the XP machine wasn't interacting with the lower layers.  The answer to the solution was to delete the winsock and winsock2 entries from the registry, reboot, and install TCP/IP over the top of the TCP/IP that was currently "installed".  Had to point the Install to the "nettcpip.inf" in the windows/inf directory.  That allows TCP/IP to install over the top of the TCP/IP required for operation of Windows XP.

I have used the /flushdns and /registerdns commands to fix quite a few problems, but this was on a home users pc, and it didn't have anywhere to register to;)

Have a great day.  Hope this helps everyone that might run into this problem twice a year;)

Blaze
0
 
LVL 5

Expert Comment

by:koquito
ID: 9883764
If I were you, I would remove the whole TCP/IP stack, including registry and files.
It changes depending on the OS you are using.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:blazetaylor
ID: 9884172
I've already got it working, but I don't know the process or even know if it's possible to "remove" the TCP/IP stack in Windows XP.

0
 
LVL 2

Expert Comment

by:dominion4thade
ID: 9885350
how did you get it working for future reference?
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 9885818
It is not possible to remove tcp from XP, it is considered a core component
but XP does have the netshell command
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q299357
0
 

Author Comment

by:blazetaylor
ID: 9889199
I used the process to remove the Winsock and Winsock2 key from the registry HKLM-System-CurrentControlSet-Services-(winsock/winsock2).  I removed these keys, rebooted.

After the reboot, I went into the Network Connection Propeties, selected install, went to "Have Disk", pointed it to the %SYSTEMROOT%/inf/nettcpip.inf file and then let it install.  Rebooted, and it all worked.  I tried the netsh command as you read above.  Didn't work, only this worked.

Hope this helps someone else!

Blaze
0
 

Expert Comment

by:vassilk
ID: 9992252
Blaze, this was a life-saver. Thanks!

I had the exact same problem of Windows 2000 stuck with a tcp/ip configuration and not accepting my dhcp settings.
... followed your steps word by word and life is better now!
0
 
LVL 5

Expert Comment

by:HighTechGeek
ID: 10093574
blazetaylor,

THANK YOU!! THANK YOU!! THANK YOU!!

I have been working on a problem XP PC for 2 days straight - 16 hours...  I knew that TCP/IP was trashed, but I couldn't figure out how to fix it.

**** How did you know about the nettcpip.inf file?? How did you find this?? ****

I didn't even delete the winsock keys... I just went straight for the Network Properties Install button. After navigating to the nettcpip.inf file and then when it came back with a choice to install the TCP/IP protocol, I was shocked, to say the least! Everything started working immediately after a reboot!!

Through this whole process, I have come across a few people with the same problem, but no solution. I will now go back and pass this along! Thanks again!
0
 

Author Comment

by:blazetaylor
ID: 10097849
Yeah, I figured it out after allot of researc on the Registry and the INF chain in XP.  It worked once so I thought I'd pay to pass it along.  

Super glad this helped someone else!

Blaze
0
 

Expert Comment

by:tech_user
ID: 10508307
Thank you BlazeTaylor

Brilliant! Worked perfectly.

I experienced this same problem just now for the second time on one PC. Last time (8 months ago)  I solved it using the Microsoft Knowledgebase article, but this time it just didn't work.

I am so glad I found this post.

Zvi
0
 

Expert Comment

by:ralmin
ID: 10535288
Just another thank you post... had exactly the same problem on a friend's laptop just now and followed the process outlined by BlazeTaylor.

First delete the two keys from the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Winsock
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinSock2

Reboot. Then go to Network Connections, Local Area Connection, Properties, Install, Protocol, Add, Have Disk, C:\WINDOWS\inf, OK, Microsoft, Internet Protocol (TCP/IP), OK. Once it's installed, reboot again.

Note that unlike HighTechGeek's experience, it did not work without first deleting the Winsock keys.

Simon.
0
 

Author Comment

by:blazetaylor
ID: 10543464
HAHA... All these "helped" people... and no points. :)

Hope this technical article makes your day better.

Blaze
0
 
LVL 5

Expert Comment

by:HighTechGeek
ID: 10543786
Blaze,

I'd give you some points if I could! :-)
I hope you're enjoying the reward of knowing that you helped us all out!
Thanks again!

HighTechGeek
0
 

Expert Comment

by:douglas14
ID: 10553399
... and the bringing people help (for no points) Blaze rollercoaster just keeps roaring on.  Like everyone else your method made networking work again.  Many thanks.
0
 

Accepted Solution

by:
CetusMOD earned 0 total points
ID: 10747038
PAQed, with points refunded (500)

CetusMOD
Community Support Moderator
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you ever set up your wireless router at home or in the office to find that you little pop-up bubble in the bottom right-hand corner of Windows read "IP Conflict - One of more computers on the network have been assigned the following IP address"…
Are you one of those front-line IT Service Desk staff fielding calls, replying to emails, all-the-while working to resolve end-user technological nightmares? I am! That's why I have put together this brief overview of tools and techniques I use in o…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Look below the covers at a subform control , and the form that is inside it. Explore properties and see how easy it is to aggregate, get statistics, and synchronize results for your data. A Microsoft Access subform is used to show relevant calcul…

782 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question