Linked Server stored procedure running VERY SLOW

I have two servers, each running win2k advance, and sql server 2000 enterprise.  Service pack 3 on both SQL Servers.  If I run the following query, I get the results back instantly

select * from linkserver.db.dbo.table where pk = 1

but if I run

declare @pk int
set @pk = 1
select * from linkserver.db.dbo.table where pk = @pk

it takes 7 minutes to return.  Any ideas what the problem is?  


LVL 9
kprestageAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LowfatspreadCommented:
what is the column type of the pk column


have you tried an openquery query instead?

 
0
kprestageAuthor Commented:
The parameter is an int data type and the column on the table is int too.  Open query wont work in this situation.  I need to get it working as a linked server.
0
LowfatspreadCommented:
how long does

declare @pk int
set @pk = 1
declare @sqlstr varchar(8000)
set @sqlstr =
'select * from linkserver.db.dbo.table where pk =' + convert(varchar(10), @pk)
exec (@sqlstr)

take?

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kprestageAuthor Commented:
less than 1 second
0
kprestageAuthor Commented:
LowFatSpread...

You didnt fix my problem, but I appreciate the help!  I think I found the solution...  The linked server were set up using the SQL Server option rather than the OLEDB Provider for SQL Server.   I created a new linked server and selected OLEDB Provider for SQL Server and then click on Provider Properties.  I set the checkbox for dynamic parameters = true for the provider, clicked apply, and then cancelled adding the new linked server.  Making that change fixed the problem on my existing linked servers!  Thanks again for your help.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.