Solved

Importing Access Database to SQL -- "no read permission" on user-level secured DB

Posted on 2003-12-04
5
944 Views
Last Modified: 2010-08-05
I have an old Microsoft Access database that I want to import into MS SQL Server 2000.  I get the following error when I try to run the import:

Error Source:  Microsoft JET Database Engine
Error Description:  Record(s) cannot be read; no read permission on [xxx] (table in old db)

I know the admin user's login and password, but when I enter that information in, I get another error:

Description:  Cannot start your application.  The workgroup information file is missing or is opened exclusively by another user.

I am assuming system.mdw is the "workgroup information file" and have put this everywhere I can think of so that SQL Server could find it.  No such luck so far.

This is urgent... any help is greatly appreciated.
0
Comment
Question by:FunkiNATEr
5 Comments
 
LVL 50

Expert Comment

by:Lowfatspread
ID: 9878638
have you tried opening the access database....
and then linking from access to sql server
and exporting your tables that way?
0
 

Author Comment

by:FunkiNATEr
ID: 9879296
Yes, but data transformation never works out and I end up getting error messages as a result.
0
 
LVL 7

Expert Comment

by:pegasys
ID: 9879625
Let me get this straight:

You _can_ open it with access normally and read the file? (y/n)?
You _can_ read while exporting???? (y/n)?

Weird...

Okay, uhm, have you tried exporting it to another format? Like excel or CSV? It may seem a bit long winded, but its a way around :-)
Excel is usually a foolprro way of (3rd party exporting), I've used it a few times with difficult databases...

IF, you are trying to use an 'ACCESS' drive, in the import wizzard, wather use something like 'Jet', that could work alot better than access drivers..

Regards

pgx()
0
 
LVL 50

Expert Comment

by:Lowfatspread
ID: 9880733
WHAT SORT OF TRANSFORMATIONS are you attempting?

? should it be the mdb file you "attach" to?
0
 
LVL 7

Accepted Solution

by:
wsteegmans earned 500 total points
ID: 9880930
> I am assuming system.mdw is the "workgroup information file" and have put this everywhere
> I can think of so that SQL Server could find it.  No such luck so far.

I suppose you're using the DTS wizard to import the Access Database. So, when you select your Access database as Source, click the Advanced Button (Advanced Connection Properties) and search for the property Jet OLEDB:System Database. As Value of this property, fill in the full path to your WorkGroup file.

After setting the WorkGroup file, fill in username (admin) and password, and try again. Should work.

Regards!
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Having an SQL database can be a big investment for a small company. Hardware, setup and of course, the price of software all add up to a big bill that some companies may not be able to absorb.  Luckily, there is a free version SQL Express, but does …
Why is this different from all of the other step by step guides?  Because I make a living as a DBA and not as a writer and I lived through this experience. Defining the name: When I talk to people they say different names on this subject stuff l…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
This videos aims to give the viewer a basic demonstration of how a user can query current session information by using the SYS_CONTEXT function

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question