Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 614
  • Last Modified:

Active Mode access to Win98 FTP server behind Linksys BEFSX41 router

I have a home LAN behind a cable modem and Linksys BEFSX41 router. One of the computers on the LAN is running Win98 and an FTP server, currently GuildFTPd.  My cable ISP has assigned me one external IP address, which gets an outside user to the cable modem/router.

The machines on my LAN are all assigned static IP addresses, in the 192.168.x.x range. In the router (this is a NAT type router with UPnP features), on the UPnP Forwarding page, I've forwarded the FTP port (assumed by the router to be 21, and not changeable) to the FTP server's static IP.

With this configuration, Passive Mode access to the FTP server works, both from the outside and from the inside (i.e. I can use an FTP client on another machine on the LAN and connect to my cable modem's external IP address, which connects me to the FTP server; I assume the cable modem is looping back).

However, I can't seem to get Active Mode to work from the outside (or looping back through the cable modem/router). Active Mode works fine if I access the server directly across the LAN via its local static IP address, but not if I go through the router (via my external IP).  If I go through the router, either from inside or outside, I get a connection to the FTP server, but then when the FTP client executes a LIST command, it fails.

I've tried all sorts of port forwarding schemes within the Linksys router without success. Incidentally, previously I was running WFTPD as the FTP server and had the same problem.

(Also incidentally, if I turn on the Passive Mode option in GuildFTPd and configure the router with a trigger port of 21 and port range forwarding for the appropriate range, I can no longer make Passive Mode connections either!)

Is there any way to set up the Linksys BEFSX41 router to allow Active Mode FTP behind it?
0
alisonnic
Asked:
alisonnic
2 Solutions
 
qwaleteeCommented:
See hre for explanation of active/passive:

http://slacksite.com/other/ftp.html
0
 
ShineOnCommented:
Active mode FTP (also known as PORT mode) uses both port 20 and 21.  Both must be available, so you need to port-translate port 20 to your Win98 box, too.

It still might not work, because many FTP clients expect to see the IP address of the server returned in a response, when doing active FTP, and if your FTP server sends your private IP address, that won't match up, and the active-mode connection will fail.
0
 
alisonnicAuthor Commented:
Apologies for not responding to this sooner, and thanks to TheLearnedOne and modulo for cleaning this up.

Also, thanks to qualetee and ShineOn for the information about Active FTP.  I wasn't able to get it to work in my situation, and I suspect that the problem was that the server was returning its local IP address, as ShineOn suggested.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now