Solved

Frames in FP 2002

Posted on 2003-12-05
11
357 Views
Last Modified: 2013-12-24
I have a page with several frames, which works OK until I change anything, e.g. the initial page in a frame. Then, just the top frame appears, though the only HTML difference looks to be the changed src name.  I suspect it's something simple that I'm doing wrong (or just not doing), but I can't figure it out.  Help, please!
0
Comment
Question by:abjohnson
  • 4
  • 4
  • 2
  • +1
11 Comments
 
LVL 6

Expert Comment

by:jdfulton
ID: 9883777
Are you sure you are previewing the correct page in your browser?  Make sure you have the main frame page which includes all of the other frames selected when you click preview in browser.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 9883872
If you supply the URL or the source code it will help us to determine the problem

-Corey
0
 

Author Comment

by:abjohnson
ID: 9883942
Hi,

Thanks for your replies.  I'm pretty sure I'm looking at the right page in the browser, not least because it works OK with the original page.

In terms of code, here's the relevant Frames Page HTML for the page that works:

<html>
<head>
<title>Veroben Solutions Limited</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<frameset rows="85,*" frameborder="NO" border="0" framespacing="0">
  <frameset cols="*" frameborder="NO" border="0" framespacing="0">
  <frame src="index5.htm" frameborder="NO" scrolling="NO" marginwidth="0" marginheight="0" target="_self">
  </frameset>
  <frameset cols="*" frameborder="NO" border="0" framespacing="0">
  <frameset rows="431,118*" frameborder="NO" border="0" framespacing="0">
    <frameset cols="*" frameborder="NO" border="0" framespacing="0">
    <frameset rows="*" frameborder="NO" border="0" framespacing="0">
      <frameset cols="264,*" frameborder="NO" border="0" framespacing="0">
      <frame src="index4.htm" marginwidth="0" marginheight="0" scrolling="NO" frameborder="NO" target="_self">
      <frame src="index3.htm" frameborder="NO" marginwidth="0" marginheight="0" name="sitewindow">
      </frameset>
    </frameset>
    </frameset>
    <frameset cols="*" frameborder="NO" border="0" framespacing="0">
    <frame src="index2.htm" frameborder="NO" scrolling="NO" marginwidth="0" marginheight="0">
    </frameset>
  </frameset>
  </frameset>
</frameset>
<noframes>
<body bgcolor="#FFFFFF" text="#000000">
</body>
</noframes>
</html>

I hope this helps.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 9883968
And what links is not working correctly?  The only one that I could find that actually did open up in the new browser - actually new window was the virtual golf.

-Corey
0
 

Author Comment

by:abjohnson
ID: 9884068
Corey,

The HTML I sent works fine.  However, if I change something, e.g. index3.htm to Handy3.htm and then save the Frames page, the next Preview in Browser shows only the top frame, i.e. index5.

[By the way, I've not published this new code yet.]

The amended HTML, which looks OK to me, is this:

<html>
<head>
<title>Veroben Solutions Limited</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<frameset rows="85,*" frameborder="NO" border="0" framespacing="0">
  <frameset cols="*" frameborder="NO" border="0" framespacing="0">
  <frame src="index5.htm" frameborder="NO" scrolling="NO" marginwidth="0" marginheight="0" target="_self">
  </frameset>
  <frameset cols="*" frameborder="NO" border="0" framespacing="0">
  <frameset rows="431,118*" frameborder="NO" border="0" framespacing="0">
    <frameset cols="*" frameborder="NO" border="0" framespacing="0">
    <frameset rows="*" frameborder="NO" border="0" framespacing="0">
      <frameset cols="264,*" frameborder="NO" border="0" framespacing="0">
      <frame src="index4.htm" marginwidth="0" marginheight="0" scrolling="NO" frameborder="NO" target="_self">
      <frame src="Handy3.htm" frameborder="NO" marginwidth="0" marginheight="0" name="sitewindow">
      </frameset>
    </frameset>
    </frameset>
    <frameset cols="*" frameborder="NO" border="0" framespacing="0">
    <frame src="index2.htm" frameborder="NO" scrolling="NO" marginwidth="0" marginheight="0">
    </frameset>
  </frameset>
  </frameset>
</frameset>
<noframes>
<body bgcolor="#FFFFFF" text="#000000">
</body>
</noframes>
</html>
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 29

Expert Comment

by:coreybryant
ID: 9884091
When you rename it - did you try to recalculate the links & then re-open the index.html file?

-Corry
0
 

Author Comment

by:abjohnson
ID: 9884114
I just reopened the index.html file.  It looks OK in Normal view, with the new page shown in the sitewindow frame, but only index5 appears in the Preview in Browser.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 9884145
Try naming all your frames.  Right now the only one that is named is the right one.

-Corey
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 9884153
Just want to make a comment if I may... The frame code you have there seems overly complicated, so it needs a little cleaning up.
Also, you're not specifying the default target for the menu links to open up in the main sitewindow frame, which is likely causing the problem...

Here's a revised frameset for you - spaced out for readability. Notice the default targets for the top and menu frame now point to "sitewindow", the main frame. Also, make sure to always give the frame pages a "name" reference, even if you're not going to be targetting them.


<html>
<head>
<title>Veroben Solutions Limited</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>

<frameset rows="85,431,*" frameborder="0" border="0" framespacing="0">

  <frame src="index5.htm" marginwidth="0" marginheight="0" name="top" scrolling="no" noresize target="sitewindow">

  <frameset cols="264,*" frameborder="0" border="0" framespacing="0">
 
  <frame src="index4.htm" marginwidth="0" marginheight="0" name="menu" scrolling="no" noresize target="sitewindow">
  <frame src="index3.htm" marginwidth="0" marginheight="0" name="sitewindow" noresize>

  </frameset>

  <frame src="index2.htm" marginwidth="0" marginheight="0" name="bottom" scrolling="no" noresize>

  <noframes>
  <body bgcolor="#FFFFFF" text="#000000">

  <p>This page uses frames, but your browser doesn't support them.</p>

  </body>
  </noframes>

</frameset>
</html>
0
 

Author Comment

by:abjohnson
ID: 9884272
That works fine!  I've tried the simple changes that didn't work before and now it's OK.  I'll sign-off on this question.  Well done, and many thanks.
0
 
LVL 31

Accepted Solution

by:
seanpowell earned 250 total points
ID: 9884379
You're very welcome - and good luck with the project!
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Now that Expression Web 4.0 (http://www.microsoft.com/expression/products/Upgrade.aspx) is free if you buy or have the full version of Expression Web 3.0, now is the best time to  migrate from FrontPage to Expression Web (http://www.frontpage-to-exp…
When setting up new project requests for our site, one of the most powerful tools our team has available to use is Axure (http://www.axure.com/). It’s a tool for creating software and web prototypes that can function and interact as if it were the a…
The purpose of this video is to demonstrate how to connect a WordPress website to Google Analytics. This will be demonstrated using a Windows 8 PC Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php :…
The purpose of this video is to demonstrate how to integrate Mailchimp with Facebook. This will be demonstrated using a Windows 8 PC. Mailchimp and Facebook will be used. Log into your Mailchimp account. : Click on your name. Go to Account Setti…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now