Error - Spoolsv.exe

I'm running a Citrix server and getting the following error:


Category: (100)
Event ID: 1000

Faulting application spoolsv.exe, version 5.2.3790.0, faulting module cpmmon.dll, version 2.3.1467.1, fault address 0x0000183b.

When the machine first logs you in, you an error about the spooler failing.  If you start the spooler service by hand, it starts, but as soon as you try to set up a printer or view the server properties in the Printers and Faxes window, it kills the service.

This is quite urgent, so max points and grade to a working solution.

Please note that this is a production box that is currently in operation, so rebooting it is a last resort.

Thoughts?
LVL 7
Robing66066Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Robing66066Author Commented:
Yeah, I read that one.  I should have mentioned that this is on a Windows 2003 box.  Sorry.
0
shivsaCommented:
Also check this link. CrazyOne has suggested good solution here,
http://www.experts-exchange.com/Operating_Systems/Win2000/Q_20435137.html
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Robing66066Author Commented:
None of those seem to apply to Windows 2003.  

0
shivsaCommented:
could u turn on drwatson and see what may be causing this problem.
0
Robing66066Author Commented:
Solved the problem.

I'd love to tell you how, but I can't.  Our Citrix guy went into regedit and changed/deleted stuff that looked "wrong".  Full credit, he got it working again, but no one, including him knows how.

C'est la vie.



0
shivsaCommented:
cpmmon.dll is citrix port monitor and spoolsv.exe is requiered to queues the jobs.
apparently interction of both causeing this problem.

1. may be u should reinstall Citrix server and see if that solves the problem. because it may be bad/corrupted dll.
0
PashaModCommented:
Question closed and points refunded

PashaMod
CS Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnnyM65Commented:
For anyone else seeking an answer to this question, please know that Citrix Hotfix XE103W2K3002.MSI corrects this problem.  The hotfix may be found at www.citrix.com


Johnny
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.