IBM 770z hangs when Starting up APM daemon and/or Starting Automount Hangs on IBM 770z

I have a IBM ThinkPad 770 w/ Windows 2K installed.  I added RH9 and when the system is booting it either hangs right after displaying Starting APM or Starting Automount.  

Grub is installed on MBR, and works great for W2K.  Have flashed current 770 BIOS - need some advice concerning how to trouble shoot & fix this.
OldArmyStuffAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jlevieCommented:
To eliminate either APM or Automount as the casue of the hang I'suggest disabling them with:

 chkconfig apmd off
 chkconfig autofs off
 chkconfig amd off       # if  the am-utils package is installed.

If the system boots normally with those disabled you can re-enable them one at a time to see which is the cause.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
OldArmyStuffAuthor Commented:
Thank you.  I am new to linux and while the system is booting I can't figure out how to get to a point to enter this commands.

Then when it displays "Starting APM Daemon" it is frozen and there is no way to "control c" out of the batch.    
0
jlevieCommented:
Okay, you'll need to boot into single user mode. Assuming you are using the Grub boot loader (the default on RedHat 9) you want to hit 'e' at the screen that shows the boot choice for RedHat. On the next screen move down to the kernel line and hit 'e' again. Add 'single' to the end of the line and hit 'b'. The system should then boot up into single user mode, which won't attempt to start apmd or autofs. From there you can disable them per the above. Once you've done so type 'exit' to boot up into multi-user mode.
0
OldArmyStuffAuthor Commented:
Thank you -- I made it thru the initial start-up and the system is working w/o those services.  I think the underlying problem relates to a 10/100 IBM Cardbus Etherjet card.  Thanks again.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.