Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Selecting Printer Properties triggers protection fault

Posted on 2003-12-05
13
Medium Priority
?
7,335 Views
Last Modified: 2009-04-16

I have two Dell 2500 notebook w 256mb ram, 900mhz
celeron, XP SP1 and a Canon BJC-80. These systems
have been working fine for quite a while.

Just today I developed a printing problems on both
notebooks  whiich shows up in two ways:

1) If I try and print anything from IE6, IE6 shuts down

2) If I select Printer Properties the following error occurs:

c:\windows\explorer.exe
Function Address 0x77e7650d caused a protection fault
exception code 0xc000005

I tried deleting and reinstalling the printer a few times and the problem still persists.

Any help suggestions would be appreciated. :-)

regards

Danjava
0
Comment
Question by:danjava
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +5
13 Comments
 
LVL 49

Expert Comment

by:sunray_2003
ID: 9885817
Check this
Troubleshooting General Printing Problems in Windows XP'
http://support.microsoft.com/?kbid=314085

Sunray
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 9885822
If this happens only when doing in IE , try repairing or reinstalling IE

Repair IE :
-----------

Start > Run rundll32 setupwbv.dll,IE6Maintenance "C:\Program Files\Internet Explorer\Setup\SETUP.EXE" /g

or

Start > Run rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\windows\inf\ie.inf

Reinstall IE:
-------------

Description of the Internet Explorer Repair Tool
http://support.microsoft.com/default.aspx?scid=http://support.microsoft.com:80/support/kb/articles/Q194/1/77.asp&NoWebContent=1

How to Reinstall or Repair Internet Explorer and Outlook Express in Windows XP
http://support.microsoft.com/?kbid=318378

or

Repair Internet Explorer 6
http://www.theeldergeek.com/repair_ie6.htm

How to Uninstall Internet Explorer 6
http://support.microsoft.com/?kbid=293907

Sunray
0
 

Author Comment

by:danjava
ID: 9885891
Sunray:

I have tried repairing IE6 and reinstalling IE6 but the problem persists.
I can print locally but cannot open Printer Properties nor print from IE6.
Same problem on two systems. Deleting Printer and reinstalling it has
not fixed the problem either.

regards and thanks

Danjava
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 49

Accepted Solution

by:
sunray_2003 earned 750 total points
ID: 9885899
You may want to check for spywares and virus ..

Also you may also think about restoring windows xp

HOW TO: Restore the Operating System to a Previous State in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;EN-US;306084 

HOW TO: Start the System Restore Tool from a Command Prompt in Windows XP
http://support.microsoft.com/?kbid=304449

HOW TO: Start Your Computer by Using the Last Known Good Configuration Feature in Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;307852&sd=tech


Sunray
0
 
LVL 38

Expert Comment

by:BillDL
ID: 9887146
Reinstall your Printer Software.  It's possible that one of the .library files that display the print dialogue is corrupt or missing.
0
 
LVL 3

Expert Comment

by:Lenney97
ID: 9975452
I had a similiar problem.  I'm have multiple Win2k workstations and a hp lj4050.  I get the GPF message when I view printer properties and print with IE.  I had one workstation that is working and I copied the spool directory inside system32 over to the one with the GPF.  What I found out was a DLL file was either corrupted or mismatched version.  When I was trying to determine the problem I reinstalled the drivers a couple times too, but that didn't help.  But in your case since you don't have a computer that is printing correctly, I suggest you make a copy of the spool directory in another location for backup purpose.  Restarte the computer to free any files in memory.  Then delete the contents inside the spool directory.  You can test to see if it is working.  If it isn't working, try to reinstall the printer drivers.  Let me know how it goes.

Lenney
0
 
LVL 2

Expert Comment

by:stonekingt
ID: 10156785
Same issue for us, but on a Win2K print server.  Our solution was to delete the printer, delete the port, re-add the port and printer.
0
 

Expert Comment

by:Boy-le
ID: 10916257
I had the same problem just after a major W2K-Update (SP4+crit+driver updates). My W2K workstation showed the same Protection fault in IE 6, and the properties of my networked HP-2200 showed an error in coming up. Printing from the server and my other W2K (not updated) did not show the problem.
Like Lenney97 I checked the spool directory, and jus copied the older (2002) files: hpbf322e.dll, hpbf322g.dll and hpbf322i.pmd from the working workstaion to the updated computer, and the problem seams to be over. It seems to be a DLL problem.
The only other file in my updated computer which is not on the other workstation is a hpbf322e.gid hidden file from some time ago, but I have not touched this one.

Boy
0
 
LVL 2

Expert Comment

by:jaseinatl
ID: 21192797
I am having the same problem on my network. I have a Small Business Server 2003 R2 and several Windows XP SP2 clients. Whenever they attempt to access the properties of one of my HP LJ1320N Printers (through a shared printer spool on my server) they get a GPF. I am using the PCl6 drivers, but I think I am going back to PCL5.

Jase
0
 
LVL 38

Expert Comment

by:BillDL
ID: 21194671
Jase

The original question here was asked way back in December 2003.  The last comment added to the question was in April 2004.  The question has been closed for a long time.
0
 
LVL 2

Expert Comment

by:jaseinatl
ID: 21200214
Well, I am a new user to this service and I still can't find a reasonable solution to my issue which is the same one listed here way back in Dec 2003.

To be honest, what does it matter if this problem first raised it's head back in 1969? If I am having the same problem in 2008 and the solutions presented don't work, wouldn't it be a valuable resource for others having this problem (and others are having this problem--I've discussed it on other boards) if someone knew or found out the answer?

I'm glad to see you have a lot of points and all and I think that this service is pretty cool. The problem I have with it is that folks are more interested in getting points and closing topics than providing help.

I should've opened a new question so you could get your points! But as it turns out, I think my question is going to be answered by another forum where the only reward they get is knowing that they helped someone out a fix.--no points, no social status, just help!

jase

jase
0
 
LVL 38

Expert Comment

by:BillDL
ID: 21210683
Hmmm.

>>> "I should've opened a new question so you could get your points!" <<<

No, you should have asked a new question so that the status was reflected as a "Question Awaiting An Answer", and would therefore be seen by experts.  

When a question awaiting answers is superseded by new ones, it slides further and further down the list until only cleanup volunteers or those who have been actively contributing tend to see it.  Once it is PAQ'd, it dies a death until someone finds it again while searching for solutions.

When a question is closed, it is assigned the PAQ status (Previously Answered Question).  A PAQ'd question will be found in a search of Experts-Exchange and the "View Solution" button should serve as a quick link to the information people may need in a hurry.

I am well aware that you are a new user, which is the reason why I took a moment to inform you that you would be flogging a dead horse by reopening a long-expired question to add a comment which in itself did not provide any updates of useful information.

I am sorry that you feel the need for sarcasm and subtle insults.  Neither was called for or deserved.
0
 

Expert Comment

by:csandelli
ID: 21879861
none of the solutions, above, worked for me.

what did work was installing the universal printer driver for the printer.

it was on a HP LaserJet 4200.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction Often we come across situations wherein our batch files would be needing to reboot Windows for a variety of reasons. A few of them would be like: (1) Setup files have been updated whose changes can take effect only after a reboot …
I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question