How do install a sound card in RedHat 9.0???

I can't seem to figure out how to configure my sound card in RedHait linux. I'm totally new to linux so please feel free to speak to me in idiot language.

I have a sound blaster 4.1 digital sound card which worked fine under windows but im getting nothing from linux, is there anything i can do to remedy this?

Thanks in advance.
roblablobAsked:
Who is Participating?
 
Aschneider00Commented:
that could have been the problem....
when u restarted the hardware config didnt see the pci sound card???  did u do all the erratta updates?  there may be an update for sound.... that may fix the "non functioning" hardware config....

another thing you can try is to backup all of you work and reinstall redhat again.... its good to go through the setup a few times anyway....

or u can intall Fedora (which is a new project) they will no longer continue with the free redhat.... fedoraproject.com is where u can dl the iso's.  I use it and it is pretty much the same as RH9 but there will be some new cutting edge technology in the versions to come...

if you dont want to do any of these i will see what I can find out about ur problem... but Fedora may be the way to go... plus they will not be issue any more updates for RH9 after Feb.  

as for the kernel thing, I am sure there are a million things you can do to the kernel, I haven't done anything with the kernel yet.  So I cannot suggest anything.  
Let me know.
Andrew
0
 
Aschneider00Commented:
go to the system settings folder from the "RH" menu... then soundcard detection... see if it sees the card and try to play the test sound.... if that works you may have to  go to preferences and enable sound server on startup.  
0
 
roblablobAuthor Commented:
thats what I initially tried but all it would detect was my onboard AC97 sound and something else I'd never heard of, and the test sounds wouldn't work. So then I tried installing this oss sound package thing and it did nothing and now I can't run the automatic sound card detection anymore!!! how annoying!!!
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Aschneider00Commented:
ddi u disable ur onboard sound in the bios?? That would cause the confusion.  RH said rather than installing 2 sound cards it didnt install any.

Check it out.  If it was disabled it wouldnt detect it.

0
 
roblablobAuthor Commented:
no i haven't disabled my onboard sound, I went and checked just to make sure. But my immediate problem is that my RH soundcard detection wont function at the moment. Is there another way of configuring my sound??
0
 
roblablobAuthor Commented:
I have seen elsewhere that you have to do something with your kernel, is this true? I'm completely new to all this so how do i go about it?
0
 
Aschneider00Commented:
just make sure the onboard sound is disabled in the BIOS b4 any of the above....  =)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.