Solved

postfix nqmgr periodical warning

Posted on 2003-12-07
6
229 Views
Last Modified: 2010-04-20
I have found on my Suse 8.2 System with Postfix runing in my mail log file the following periodical warning (exactly every minute)

"server postfix/nqmgr[10175]: warning:connect to transport smtp:Connection refused"

Anyone an idea why the postfix queue manager do this every minute ?

Thanks !

0
Comment
Question by:and882
  • 3
6 Comments
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 9891923
It's doing this every minute because the transport_retry_time is set to 60 seconds :-)

But this is probably not what you wanted to know. So let's find out what's wrong with your system:

Is mail still getting delivered?
Do you have any idea when your system started to print this message? Was it after a change you made to the postfix config files?
Did you manually change the postfix config files?
Is the mydestination variable set correctly to all your hostnames?
0
 

Author Comment

by:and882
ID: 9892147
Thanks for the answer.

I can receive emails without any problems.

The problem starts without any (known) reason. I have changed nothing.

Yes, I manually have changed the postfix files - but for over a mouth everthing works :-)

when I try to send an email, I find it in /var/spool/postfix/deferred:

A.client_name = unknown (-> no dns possible, this should not be a problem ?) A.client_address = 10.10.0.254 (this is my router)

mydestination = $myhostname, localhost.$mydomain, $mydomain


0
 
LVL 44

Accepted Solution

by:
Karl Heinz Kremer earned 100 total points
ID: 9892244
Is the myhostname variable set correctly?

To me it seems that your queue manager tries to connect to an smtp server, and is not allowed to do so. Something must have changed since you first set up this machine. These messages don't just start without any good reason.

Did you change anything else in the network setup? Why is it reporting an error with your router address? Are you trying to relay your emails to the router (which would probably be wrong)? Is the setting of relayhost correct? If you put the hostname into square brackets, postfix will not try any DNS lookup:

relayhost = [smtp-server.your.provider.com]

Are email messages going out as well?
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 10328692

No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
Answered by khkremer
Please leave any comments here within the next four days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

khkremer
EE Cleanup Volunteer
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Network Interface Card (NIC) bonding, also known as link aggregation, NIC teaming and trunking, is an important concept to understand and implement in any environment where high availability is of concern. Using this feature, a server administrator …
If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question