windows XP logging in as Guest account

Hi

I am getting this problem that everytime a user tries to connect to another computer "\\computername\c$" on a workgroup it automatically tries to connect through /computername/Guest and asks for a password. even though i have disableed the Guest account.

One more thing is that when i try to connect through Guest account it does'nt let me connect. how do i make windows xp not automatically connect through Guest account.

Help me out asap

Thanks in Advance
LVL 1
lomareeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sramesh2kCommented:
For XP Professional, disable Simple File Sharing in the Explorer > Tools > Folder Options
0
lomareeAuthor Commented:
still the problem is there.. what do i do.. i can't seems to understand why XP pro is automatially trying to access with Guest account of that computer even though it's disabled .
0
sramesh2kCommented:
I forgot to mention that you need to disable simple file sharing in the machine which accepts the connection. Restart.

Identical user accounts with matching passwords must be created on two computers (to enable transparent sharing) or the user must type a user name and password when connecting.

Also, disable the policy "Force Network Logons using Local Accounts to Authenticate as Guest"

http://www.nthelp.com/NT6/xp_drive_sharing.htm
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

lomareeAuthor Commented:
i can't find this policy "Force Network Logons using Local Accounts to Authenticate as Guest" in the local security settings , where do i change it then
0
sramesh2kCommented:
Start | Run | Secpol.msc
Local Policies | Security Options

"Network access: Sharing and security for local accounts"
Double-click it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TwirlspinCommented:
A work-around for the above is the following:

attempt to map to \\computername\C$ but choose different login username prior to clicking on OK.  In the USername field type  computername\username    The username needs to be one that has admin rights to that PC and the computername is the name of the computer you are tryting to attach to.

Then type that usernames password in the field provided.  Click on OK then OK again.  And you should be able to attach to that PC.  Not my preffered way to attach due to security concerns, but it should at least get you connected till you work out the issues above.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.