?
Solved

Shares on Windows 2003 are Read-only by default!!! Even if I deselect read-only tag

Posted on 2003-12-08
13
Medium Priority
?
1,273 Views
Last Modified: 2010-04-14
Hi,

When making a share on Win2k3 the read-only tag is selected but grey. If I deselect it and close and open the Share properties, the read only is back on??? Tried to delete a file with admin permissions but nope, access violation...


Pls Help

Network mixed 2000/2003 server, Win 2k and XP WKS.


jurgen
0
Comment
Question by:ezjurgen
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
  • +2
13 Comments
 
LVL 32

Expert Comment

by:LucF
ID: 9897007
Hi ezjurgen,

You should try to uncheck the "Allow inheritable permissions from parent to propagate to this object" and then set the settings as you want them to be.

Greetings,

LucF
0
 
LVL 4

Expert Comment

by:Vinnnnie
ID: 9897376
Remove the user and re-add user back in. Make sure user has permissions to that resource and make sure it is not sub-shared, like it being already in a folder with something already shared above it, if that makes sense.
0
 
LVL 1

Expert Comment

by:cawelty
ID: 9899852
Jurgen,

I saw this when we went to server 2003.  According to microsoft this is by design.  In fact all the folders on our servers still show read only in the way you described, but everyone who has permission to the folders is able to write to them
see this article
http://support.microsoft.com/?kbid=256614
0
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

 
LVL 1

Author Comment

by:ezjurgen
ID: 9903637
Well, I share a folder on server X (2003) Give myself (administrator) full rights, do not allow propagation from above. Go to a WKS (XP pro) and browse to the folder.... Icannot create or delete anything!!!!!


pls respond

jurgen
0
 
LVL 32

Expert Comment

by:LucF
ID: 9903865
Have you logged off and logged on again on the XP workstation? That makes sure the profile is updated for this kind of permissions.
0
 
LVL 4

Expert Comment

by:Vinnnnie
ID: 9904457
Does this happen on your 2000 PCs or just your XP PCs?
0
 
LVL 1

Expert Comment

by:cawelty
ID: 9904771
Are you unable to create or delete anything in that folder when you are directly on the server?  Or does this only happen when accessing a shared folder from a client workstation?
0
 
LVL 1

Expert Comment

by:cawelty
ID: 9904821
I was just able to reproduce what you are talking about.  I created a share gave myself full control and accessed it from a client workstation.  I was unable to create or delete anything in this folder.  I then went back to the folder on the server and went to the sharing tab and gave myself full control there and I was then able to create and delete files, (the default share permissions was everyone read only).  So my suggestion is on the sharing tab give yourself full control permissions there.
0
 
LVL 4

Assisted Solution

by:Vinnnnie
Vinnnnie earned 120 total points
ID: 9904866
You may also want to check the security tab right next to the sharing tab. That one needs to be enabled as well for some weird reason.
0
 
LVL 1

Accepted Solution

by:
cawelty earned 140 total points
ID: 9904961
more info on my earlier comment...

Share permissions by default in 2003 are everyone read only. Since the share permissions are more restrictive than the ntfs permissions, the share permissions apply...see the full article from Microsoft here.  http://tinyurl.com/yfaq

0
 
LVL 1

Author Comment

by:ezjurgen
ID: 9942131
Thanks guys,

I feel so stupid, i only looked under the NTFS permissions, never under the old Share perms.... Unticked read only there and my headache was over

thanks



ez
0
 

Expert Comment

by:danofre
ID: 10106648
That does not work for me.
.... Unticked read only there is no read only box.
Why is every answer so vague.
Spell it out for me.
0
 
LVL 32

Expert Comment

by:LucF
ID: 10106692
Why don't you create your own question?
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
This month, Experts Exchange’s free Course of the Month is focused on CompTIA IT Fundamentals.
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
Suggested Courses
Course of the Month10 days, 1 hour left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question