Solved

no sound :(

Posted on 2003-12-08
11
654 Views
Last Modified: 2010-08-05
i have detected sound card and the test sound plays perfectly but the cd player doesnt seem to work together with the sound card. i have set up the volume but it really doesnt work.
this might just be me, i dont know, im a noob in linux
0
Comment
Question by:Tai-San
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +4
11 Comments
 
LVL 2

Author Comment

by:Tai-San
ID: 9897598
i have a soundblaster live! 5.1 bulk card
0
 
LVL 9

Expert Comment

by:majorwoo
ID: 9897996
there are a few options

#1 - does the CD play music in windows? you may not have the audio cable from the CDROM to your sound card plugged in

#2 - if it plays in windows, check your mixer to see if the CD is muted/turned way down

failing both of those (it looks like you tried #2) what do you mean by it doesn't work, what exactly does it do, and where exactly does it fail?
0
 
LVL 5

Expert Comment

by:willy134
ID: 9899348
what distro are you using?  Are you using ALSA (can be seen in startup messages)  more info would be helpful.

If you are using alsa you may need to run alsaconfig or soundconfig or whatever config your distro gives you.  Your volume might be turned down adn you need to run a mixer like kmix or alsamixer or aumix or whatever mixer comes with your distro.
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 2

Author Comment

by:Tai-San
ID: 9899357
i dont get any sound, the cds plays well in windows and it shows that theres audio comming.
do i need a new mp3 player?
0
 
LVL 9

Expert Comment

by:majorwoo
ID: 9899734
Tai-San

you need to help us help you, once again:

What distribution of Linux? (redhat, suse, etc)

Are you using ALSA or OSS for your sound? (if you don't know, please describe the install method you used for your distribution)

majorwoo
0
 
LVL 3

Expert Comment

by:raybass
ID: 9909667
By default, your mixer is getting "cd" sound from the physical cd input on your sound card, no matter what sound driver you use.  This means analog audio, which means it is sound that travels down the sound cable running from the cd player to the sound card.  This is often disadvantageous, since many people want to play CDs in more than one cd drive, and can't because they only have one cable.

A better solution is to use the package known as xmms-cdread.  This will play your audio through the data cable and will be included under the PCM volume level in your mixer, which is used to play wav files and mp3s and such.

I don't know what distribution you are using, so I can't give you a download link, but you should find it in your favorite RPM/apt/tar.gz source location.

Good luck!
0
 
LVL 3

Expert Comment

by:raybass
ID: 9909675
oops, adding to that, that means you have to play your CDs through your x multimedia system (xmms), which is a great all around winamp-type sound player for linux if you're not familiar with it.  hope that helps.
0
 

Expert Comment

by:sublum
ID: 9943819
just a note: No, you don't need an mp3 player to play an ordinary CD,

There is a possibility that you're not in the right system 'group', to be able to access the CD device.

If you have root access to the machine, you can try playing an audio CD while you're logged-in as the root user,. If it works then, but not as your regular user, then it's most certainly an issue of the user/group and file permissions on the CD device.


The problem, here, would be:  If you (really, your system 'user') don't have permissions to read from the CD device, then your sound applications  will not be able to get the data from the CD, in order to make the sound with


To check the group that is set on the CD device, you can run 'ls -l' on the device that your kernel will be using, to access the CD drive.

If you're using a plain IDE driver for the CD drive (this should be the most common case, if it is a regular CD/ROM drive and not a CD/RW drive), run this command:

ls -l /dev/hdc


If you're using a SCSI CD drive, or using IDE-SCSI emulation  on an IDE drive,, run this command:

ls -l /dev/scd0


Then, you should see some output, like the following, from the 'ls' command:

For IDE devices:

brw-rw----    1 root     disk      22,   0 2002-03-14 13:51 /dev/hdc

For SCI and IDE-SCSI emulation:

brw-rw----    1 root     cdrom     11,   0 2002-03-14 13:54 /dev/scd0


Your system may have different user/group names there -- rather than root/disk or root/cdrom; ("root" is usually the user on it, but who knows what each installation has, really)

The important thing to notice, for this, is the 'group' name show, by "ls -l", on the device.

For the IDE device,, as shown above, the group name is "disk".
In the second example -- for the SCSI/IDE-SCSI device, -- the group name is "cdrom"

Again: your Linux installation may use different groups on those devices. Whichever group it /does/ use for the CD device, that's what you'll need to remember


Now, a seperate step:

run the 'groups' command.

It will show you the list of system 'groups' that  you're a member of,

if the appropriate group, for your CD/ROM device, does not show up in that llist, then you'll need to add yoursel to that group.

You should refer to the documentation for your Linux distribution, to find the application that your Linux distributor recommends, for adding a user to a group.

You'll need to add your regular user name to the group that was shown on the CD device.



If all else fails, here, then you should be able to use 'vigr' for adding a user name to a group.

Simply run the command:

vigr


Then, in the editor that 'vigr' launches, find the line on which the desired group-name is listed as the first field, like so:

cdrom:x:24:

the exact group ID value (24) there, isn't important for this, nor is the "x"  in the second field.

What you'll need to do is to add your regular user name to the list of users in that group. To do this, add your group name after the last colon character, like so:

cdrom:x:24:myUname

...but, using your regular user name instead of "myUname"

If  one or more user-names already exists in that group-members field, then seperate the group names with commas, like so:

cdrom:x:24:user1,user2


Remember, as well, that you'll have to do this for the particular group that was shown as having permissions on the CD device.

Once that information is edited, and the file saved, then exit the  'vigr' application. The system should then begin to recognize you as being a member of that group.


However, after you've added yoursef to the group, you'll need to log out of the system, then log back in again, for the change to be fully recognized by the system.  The 'sg' and 'newgrp' commands can be used as something of a workaround for this; you can refer to their manual pages, for more information.




So, that ends it.

I hope that this will help you to get your CD audio working, now.


Good afternooon.


--
Sean
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 10338288
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
PAQ/No Refund
Please leave any comments here within the next four days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

khkremer
EE Cleanup Volunteer
0
 

Accepted Solution

by:
PashaMod earned 0 total points
ID: 10364754
PAQed - no points refunded (of 50)

PashaMod
Community Support Moderator
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question