?
Solved

Microsoft IIS SMTP Server error-> 550 error

Posted on 2003-12-08
3
Medium Priority
?
17,786 Views
Last Modified: 2010-07-27
I am trying to setup a SMTP server (email receipts for our commerce site), and I receive a 550 error. Below is what I grabbed from telnet:

rcpt to: <ryanr@nni.com>
550 5.7.1 Unable to relay for ryanr@nni.com

When I authenticate, it sends fine. However, the components for the site (SendSMTP) cannot authenticate. In terms of security, I restricted the server to only accept emails from its own ip, perform r-dns on all attempts to use the server, and blocked off port 25 at the router (incoming connections). Hopefully that will keep the spammers at bay.

Unfortunately, I cannot seem to get the server to send its test message, much less any emails. The Commerce App is running on high-levels accounts, so there shouldn't be any problems. Any ideas what is going on here? Perhaps I forgot to configure something.

Oh yeah, this server is running on IIS 6.0, on Windows 2003 EE.
0
Comment
Question by:rossryan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 8

Accepted Solution

by:
JasonBigham earned 1000 total points
ID: 9897985
"I restricted the server to only accept emails from its own ip"

Then you will only be able to send a test email FROM that server(no clients). I imagine you will at least be adding two other IP's. One from your ISP, and one from whatever is sending mail to this box off your LAN. Where is your mail going TO? Are you using the SmartHost option or DNS(mx records needed)?

One method(i use this with a smarthost on the mail server and the iis gateway):
Clients ---> mail server --> iis gateway --> ISP
               
The former has to be allowed to relay by the latter.

I.E.

iis gateway allows the IP addrsss from the mail server to relay.
0
 

Author Comment

by:rossryan
ID: 9898344
Fixed it. Forgot to add the localhost to the authorized relays.

Thanks,
Ryan
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The biggest nightmare for any Exchange Server Administrator is to keep the server running without any issue. But the problems often come and they need to be resolved efficiently and timely. Here are important troubleshooting points: Define the Pr…
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
This Micro Tutorial will demonstrate the easy use of Gmail embedding images in your email so the recipient of your email can view them in context.
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question