rsh is working for root, but not for other users? --urgent

Posted on 2003-12-08
Last Modified: 2013-12-15
Hi All,

I have installed rsh server and is working fine for the root but not for other users.

if i say ls -l /usr/bin/rsh it gives
-rwsr-xr-x    1 root     root         7764 Feb  5  2001 /usr/bin/rsh

the setuid has been set, but still rsh is not working for other users.
What else need to be changed??


Question by:mantram
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
LVL 22

Expert Comment

ID: 9900181
What error are you getting when you try to use rsh?

Does using the full path:


work for other users? If so you need to add /usr/bin/ to your path
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 9900212
You should not use rsh at all. It's a security risk.

Use the secure shell (ssh) instead. It supports all that rsh does and more (e.g. X11 tunneling). Chances are that your distribution does have OpenSSH, you just need to install it. You an also get it from

You can find more information about the problems with the "r" commands at CERT:

BTW: If you question is really that urgent, you should offer more points. The EE guidelines for points suggest 20 points for a not urgent, not complicated question.
LVL 22

Expert Comment

ID: 9900473
I confess that I use rsh for a few things, but access is greatly restricted to the system/network concerned. However, I agree ssh is the recommended approach for most circumstances:)
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!


Author Comment

ID: 9900890
Thanks buddies!!!  But I need rsh to run a tool, infact SPEcsfs benchmark.


The error I am getting is "rcmd: socket: oermission denied"
I tried using the full path too /usr/bin/rsh but getting the same error.

LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 9901316
Depending on your distribution, the rsh will use e.g. PAM for authentication. Check the directory /etc/pam.d/ for a file named rsh (or wherever PAM on your system stores it's config files).
Try to rlogin into your system. If this works for non-root users, copy the contents of the rlogin file to the rsh file in the PAM directory.
I just installed rsh (for the first time in ten years) on my Linux system, and that's what I had to do in order to get it to work.
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 9901321
These changes need to be made on the server.

Author Comment

ID: 9901606
I got rsh working :)
have setuid for rsh as well as rlogin, since rsh also needs rlogin...

Thanks all

Accepted Solution

CetusMOD earned 0 total points
ID: 15644834
PAQed with points refunded (20)

Community Support Moderator

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Unbreakable Oracle Linux 6.8 installation problem 9 58
umask commands 5 13
sed command 3 20
Bash script to include windows servers 13 36
How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question