Solved

Bit torrent through firewall -- i ve read alot but it doesn't seem to work

Posted on 2003-12-08
11
55,665 Views
Last Modified: 2011-08-18
i want to download things with bit torrent but they are goin at speeds like 1-5 kb even though i have dsl

i disabled the windows firewall and i have not installed any software ones.  i am using a netgear router and i went to to 192.168.0.1 and went to port forwarding, but i don't exactly know what it means.  any suggestions?

ask me and i will tell you more info
0
Comment
Question by:djiangr
11 Comments
 
LVL 5

Expert Comment

by:Goofytouy
ID: 9905980

Which is the bandwidth of your dsl?

what do you mean with "i went to 192.168.0.1"?

0
 

Author Comment

by:djiangr
ID: 9906088
192.168.0.1 is my router's address and i found that on the router's website.  i used the port fowarding and opened up the ports 6881-6899 (whcih were used in bittorrent) but it was still slow.  I am not sure of my dsl's bandwidth, where can you find out?  well i know that when downloading other things w/o using bittorrnet (such as kazaa or just something on a webpge) it often goes up to over 100 kb, kazaa probably 50 kb.

0
 

Accepted Solution

by:
raphael_999 earned 125 total points
ID: 9910165
technically a firewall shouldn't slow down a transfer whatever the port is....
The fact is : bittorrent is based on sharing so if your settings are blocking the upload, it will significally slow down your transfer rate...

Go there : http://ei.kefro.st/projects/btclient/
and download their EXPERIMENTAL client.  It works like the regular one but it allows you to change your uploads settings.

I had the same problem a while ago.  I was downloading at like 1 or 2 kb/sec
when I set the upload rate and the max uploads settings to 5000 and 100,
I get a 80kb/sec download rate...

Hope it helps
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 11

Expert Comment

by:turn123
ID: 10185515
djiangr,
No comment has been added lately (45 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: Award points to raphael_999 http:#9910165

Please leave any comments here within 7 days.

-- Please DO NOT accept this comment as an answer ! --

Thanks,

turn123
EE Cleanup Volunteer
0
 
LVL 2

Expert Comment

by:happispider
ID: 10338914
BitTorrent seems to me to really need to not be behind a firewall, to speed up downloads...

If you have access to your router (ofter http://192.168.1.1) open it and set forwarding to forward on ports 4000-7000 on your IP and your IP alone...  6000-7000 because I don't know the exact ports to forward on. Don't forward these ports on another computer at the same time: when I do that one computer ends up with closed ports.

http://192.168.1.1-->forward ports 4000-7000

Maybe it should be ports 4444-7000 instead to avoid Blaster.
0
 

Expert Comment

by:charlesg
ID: 10441462
Never EVER open ports on your router unless you know what you're doing. Especially not a range of 3000!!!

BitTorrent uses ports 6881-6889 by default.
0
 

Expert Comment

by:nyfaisal
ID: 10587243
I use university connection, and can't use bittorrent at all. I read about port forwarding in different websites to solve this.  I am not using a router.  How do I setup port forwarding in windows XP to solve this problem?
0
 
LVL 5

Expert Comment

by:Goofytouy
ID: 10597158

Post a new question, and for sure an expert will help you.


GoofytoUy
0
 

Expert Comment

by:nyfaisal
ID: 11511647
I can make it work with Time Warner cable and port forwarding enabled in my router.  However, if your ISP is blocking the whole 688x range of ports, then it'll be unlikely that you can use bittorrent. Try E-mule instead-- its slowwwww, but at least works.
0
 
LVL 1

Expert Comment

by:sazukaChan
ID: 11816166
i use bittorrent too and it runs fine on the router that we have set up.  i use zonalarm as my firewall, and i just check accept when it asks for internet permission.  if its not that then take other people's advice about routing.  good luck with this.
0
 

Expert Comment

by:antheus
ID: 14693196
regarding setting your upload to the max, this isn't necessarily the best idea because it's possible that by maxing out your upload rate you'll severely limit your download rate.  It's best to set it a bit below your max.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Free software for pdf to word conversion 4 77
forensics tools for file amendments/associations 2 104
Christmas family picture with greetings 19 126
Cannot install SkypeSetup.exe 4 41
Workplace bullying has increased with the use of email and social media. Retain evidence of this with email archiving to protect your employees.
Healthcare organizations in the United States must adhere to the guidance of both the HIPAA (Health Insurance Portability and Accountability Act) and HITECH (Health Information Technology for Economic and Clinical Health Act) for securing and protec…
The viewer will learn how to set up a document for the web and print and the recommended PPI for printing.
The viewer will learn how to create multiple layers to apply various filters and how to delete areas from each layer’s filter.

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question